summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-04-03 16:19:50 +0200
committerhaawda2020-04-03 16:19:50 +0200
commit04d568dba307009c9019279f08691eb9c03c3158 (patch)
tree37e067021f3066051af2d65a0614f62176fc366e
parentcfd12b1a8987e3083786a1b1d17c7b68df6ce89f (diff)
downloadaur-04d568dba307009c9019279f08691eb9c03c3158.tar.gz
Update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b59e851f0116..d2a2065bd9ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pymacs
pkgdesc = Interface between Emacs Lisp and Python.
- pkgver = 0.25
- pkgrel = 3
- url = http://pymacs.progiciels-bpi.ca/
+ pkgver = 0.26
+ pkgrel = 1
+ url = https://github.com/dgentry/Pymacs
install = pymacs.install
arch = any
license = GPL2
@@ -11,8 +11,8 @@ pkgbase = pymacs
makedepends = texlive-core
depends = emacs
conflicts = emacs-python-mode
- source = pymacs-0.25.tar.gz::https://github.com/pinard/Pymacs/tarball/v0.25
- md5sums = 3573a1fe20a4afabb7c980d2deac2bdf
+ source = pymacs-0.26.tar.gz::https://github.com/dgentry/Pymacs/archive/v0.26.tar.gz
+ sha256sums = e876a48a7540d45956fc1c3e623efe638a2093a580c9ab591ebceed0cd7bc707
pkgname = pymacs
diff --git a/PKGBUILD b/PKGBUILD
index 2ef966f78121..7f78f5531cc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,28 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=pymacs
-pkgver=0.25
-pkgrel=3
-_gitrel=5989046
+pkgver=0.26
+pkgrel=1
pkgdesc='Interface between Emacs Lisp and Python.'
arch=('any')
-url='http://pymacs.progiciels-bpi.ca/'
+url='https://github.com/dgentry/Pymacs'
license=('GPL2')
depends=('emacs')
makedepends=('python2' 'python2-docutils' 'texlive-core')
conflicts=('emacs-python-mode')
-source=($pkgname-$pkgver.tar.gz::https://github.com/pinard/Pymacs/tarball/v0.25)
-md5sums=('3573a1fe20a4afabb7c980d2deac2bdf')
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha256sums=('e876a48a7540d45956fc1c3e623efe638a2093a580c9ab591ebceed0cd7bc707')
install=$pkgname.install
build() {
- cd pinard-P${pkgname:1}-${_gitrel}
+ cd ${pkgname//p/P}-${pkgver}
make PYTHON=python2 PREFIX=/usr
emacs -batch -f batch-byte-compile pymacs.el
python2 ./setup.py build
}
package() {
- cd pinard-P${pkgname:1}-${_gitrel}
+ cd ${pkgname//p/P}-${pkgver}
python2 ./setup.py install --prefix="$pkgdir"/usr
install -d "$pkgdir"/usr/share/emacs/site-lisp
install -m 644 $pkgname.{el,elc} "$pkgdir"/usr/share/emacs/site-lisp