summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-04-03 16:37:42 +0200
committerhaawda2020-04-03 16:37:42 +0200
commita50167e32d260559ef4ffe9543a84910febc76b3 (patch)
tree8eda7d9760f0d3a563b9b1a5d7acb681136bce50
parent04d568dba307009c9019279f08691eb9c03c3158 (diff)
downloadaur-a50167e32d260559ef4ffe9543a84910febc76b3.tar.gz
use python, not python2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2a2065bd9ae..b7b0d5fdbe5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = pymacs
pkgdesc = Interface between Emacs Lisp and Python.
pkgver = 0.26
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dgentry/Pymacs
install = pymacs.install
arch = any
license = GPL2
- makedepends = python2
- makedepends = python2-docutils
- makedepends = texlive-core
+ makedepends = python
+ makedepends = python-docutils
depends = emacs
conflicts = emacs-python-mode
source = pymacs-0.26.tar.gz::https://github.com/dgentry/Pymacs/archive/v0.26.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 7f78f5531cc9..834bf5ce696b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=pymacs
pkgver=0.26
-pkgrel=1
+pkgrel=2
pkgdesc='Interface between Emacs Lisp and Python.'
arch=('any')
url='https://github.com/dgentry/Pymacs'
license=('GPL2')
depends=('emacs')
-makedepends=('python2' 'python2-docutils' 'texlive-core')
+makedepends=('python' 'python-docutils')
conflicts=('emacs-python-mode')
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
sha256sums=('e876a48a7540d45956fc1c3e623efe638a2093a580c9ab591ebceed0cd7bc707')
@@ -18,14 +18,14 @@ install=$pkgname.install
build() {
cd ${pkgname//p/P}-${pkgver}
- make PYTHON=python2 PREFIX=/usr
+ make PREFIX=/usr
emacs -batch -f batch-byte-compile pymacs.el
- python2 ./setup.py build
+ python ./setup.py build
}
package() {
cd ${pkgname//p/P}-${pkgver}
- python2 ./setup.py install --prefix="$pkgdir"/usr
+ python ./setup.py install --prefix="$pkgdir"/usr
install -d "$pkgdir"/usr/share/emacs/site-lisp
install -m 644 $pkgname.{el,elc} "$pkgdir"/usr/share/emacs/site-lisp
}