summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorP. A. López-Valencia2015-07-07 16:46:17 -0500
committerP. A. López-Valencia2015-07-07 16:46:17 -0500
commitf2c24f98973c6a0c785ba76d0b915043287c6972 (patch)
tree92b121020889ffa9d68f8a407ccd5df0d0d70e8c
downloadaur-f2c24f98973c6a0c785ba76d0b915043287c6972.tar.gz
0.25-2
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD34
-rw-r--r--pymacs.install6
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0235ff37e19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pymacs
+ pkgdesc = Interface between Emacs Lisp and Python.
+ pkgver = 0.25
+ pkgrel = 2
+ url = http://pymacs.progiciels-bpi.ca/
+ install = pymacs.install
+ arch = any
+ license = GPL2
+ makedepends = python2
+ makedepends = python2-docutils
+ makedepends = texlive-core
+ depends = emacs
+ conflicts = emacs-python-mode
+ source = pymacs-0.25.tar.gz::https://github.com/pinard/Pymacs/tarball/v0.25
+ md5sums = 3573a1fe20a4afabb7c980d2deac2bdf
+
+pkgname = pymacs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fa9b07747604
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*~
+pkg/
+src/
+*.gz
+*.bz2
+*.xz
+*.lzo
+*.xz4
+*.tgz
+*.tbz
+*.txz
+*.tar
+*.jar
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34bb287d0533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Tiago Pierezan Camargo <tcamargo@gmail.com>
+# Contributor: Richard Murri <admin@richardmurri.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=pymacs
+pkgver=0.25
+pkgrel=2
+_gitrel=5989046
+pkgdesc='Interface between Emacs Lisp and Python.'
+arch=('any')
+url='http://pymacs.progiciels-bpi.ca/'
+license=('GPL2')
+depends=('emacs')
+makedepends=('python2' 'python2-docutils' 'texlive-core')
+conflicts=('emacs-python-mode')
+source=($pkgname-$pkgver.tar.gz::https://github.com/pinard/Pymacs/tarball/v0.25)
+md5sums=('3573a1fe20a4afabb7c980d2deac2bdf')
+install=$pkgname.install
+
+build() {
+ cd ${srcdir}/pinard-P${pkgname:1}-${_gitrel}
+ make PYTHON=python2 PREFIX=/usr
+ make PYTHON=python2 RST2LATEX=rst2latex2 pymacs.pdf
+ emacs -batch -f batch-byte-compile pymacs.el
+ python2 ./setup.py build
+}
+package() {
+ cd ${srcdir}/pinard-P${pkgname:1}-${_gitrel}
+ python2 ./setup.py install --prefix=${pkgdir}/usr
+ install -d ${pkgdir}/usr/share/emacs/site-lisp
+ install -m 644 $pkgname.{el,elc} ${pkgdir}/usr/share/emacs/site-lisp
+ install -Dm644 $pkgname.pdf ${pkgdir}/usr/share/doc/$pkgname/$pkgname.pdf
+ cp -r contrib ${pkgdir}/usr/share/doc/$pkgname/
+}
diff --git a/pymacs.install b/pymacs.install
new file mode 100644
index 000000000000..bf014864dde4
--- /dev/null
+++ b/pymacs.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "set PYMACS_PYTHON=python2 in your environment"
+ echo "if your pymacs-scripts should be run by the classical python."
+}
+
+