summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-07-17 10:07:15 -0600
committerMark Wagie2020-07-17 10:07:15 -0600
commit1515acade4084a82137843712b822b29c49d60fb (patch)
tree29bae064dd901b12645160c6c54002b2146538ff
parent34af921e320d04129856f8d1528494d77c48b0ce (diff)
downloadaur-1515acade4084a82137843712b822b29c49d60fb.tar.gz
updated to 7.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eaa65c60db6..8813da653299 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = pymdown-extensions
pkgdesc = Extensions for Python Markdown
- pkgver = 6.3.0
+ pkgver = 7.1
pkgrel = 1
- url = http://facelessuser.github.io/pymdown-extensions/
+ url = http://facelessuser.github.io/pymdown-extensions
arch = any
license = MIT
makedepends = python-setuptools
- source = https://github.com/facelessuser/pymdown-extensions/archive/6.3.0.tar.gz
- sha256sums = 9e2f98bbc31c76cfd0001b58c45b1a8add66d279f289f5c5b850778a4e771c22
+ depends = python-markdown>3.2
+ optdepends = python-pygments
+ source = https://pypi.org/packages/source/p/pymdown-extensions/pymdown-extensions-7.1.tar.gz
+ sha256sums = 5bf93d1ccd8281948cd7c559eb363e59b179b5373478e8a7195cf4b78e3c11b6
pkgname = pymdown-extensions
diff --git a/PKGBUILD b/PKGBUILD
index b8be194c139a..ebc366b5eda4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
-# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Duru Can Celasun <can at dcc dot im>
pkgname=pymdown-extensions
-pkgver=6.3.0
+pkgver=7.1
pkgrel=1
pkgdesc="Extensions for Python Markdown"
-arch=("any")
-url="http://facelessuser.github.io/pymdown-extensions/"
-license=("MIT")
-makedepends=("python-setuptools")
-source=("https://github.com/facelessuser/pymdown-extensions/archive/${pkgver}.tar.gz")
-sha256sums=('9e2f98bbc31c76cfd0001b58c45b1a8add66d279f289f5c5b850778a4e771c22')
+arch=('any')
+url="http://facelessuser.github.io/pymdown-extensions"
+license=('MIT')
+depends=('python-markdown>3.2')
+makedepends=('python-setuptools')
+optdepends=('python-pygments')
+source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
+#source=("$pkgname-$pkgver.tar.gz::https://github.com/facelessuser/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('5bf93d1ccd8281948cd7c559eb363e59b179b5373478e8a7195cf4b78e3c11b6')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+ cd "$pkgname-$pkgver"
+ python setup.py build
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}"
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname"
}