summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD. Can Celasun2017-05-31 12:42:53 +0200
committerD. Can Celasun2017-05-31 12:42:53 +0200
commitf6c6188cadb547717b9e0aaa55240272d25a0ea5 (patch)
treed7746b73fb64db52a60a9f01f721fb1413b1e495
downloadaur-f6c6188cadb547717b9e0aaa55240272d25a0ea5.tar.gz
Add pymdown-extensions
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92e816c21fc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed May 31 10:42:27 UTC 2017
+pkgbase = pymdown-extensions
+ pkgdesc = Extensions for Python Markdown
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = http://facelessuser.github.io/pymdown-extensions/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ source = https://github.com/facelessuser/pymdown-extensions/archive/3.3.0.tar.gz
+ sha256sums = 57ab382a5658bc60c4ddb60ff60323de1854c9c476700ff1318ec088c5322d23
+
+pkgname = pymdown-extensions
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4112c3603bc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
+pkgname="pymdown-extensions"
+pkgver=3.3.0
+pkgrel=1
+pkgdesc="Extensions for Python Markdown"
+arch=("any")
+url="http://facelessuser.github.io/pymdown-extensions/"
+license=("MIT")
+makedepends=("python-setuptools")
+source=("https://github.com/facelessuser/pymdown-extensions/archive/${pkgver}.tar.gz")
+sha256sums=('57ab382a5658bc60c4ddb60ff60323de1854c9c476700ff1318ec088c5322d23')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+}