summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Revilla2018-12-25 11:22:28 +0100
committerMiguel Revilla2018-12-25 11:22:28 +0100
commitf30344fdfba40b40c8721553b1faa1486284df0b (patch)
tree98c3ff9f38dcf27e0b6a80dbb623e2acf2df17b6
parent51d86e4791951a47bf608be879c25159a35ac9ff (diff)
downloadaur-f30344fdfba40b40c8721553b1faa1486284df0b.tar.gz
Update to 1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20b6a0c95876..d005a70d7013 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Thu Aug 25 08:12:53 UTC 2016
pkgbase = pymetar
pkgdesc = downloads the weather report for a given station ID, decodes it and the provides easy access to all the data found in the report
- pkgver = 0.21
+ pkgver = 1.0
pkgrel = 1
url = http://www.schwarzvogel.de/software-pymetar.shtml
arch = i686
arch = x86_64
license = GPL2
- depends = python2>=2.7
- source = http://www.schwarzvogel.de/pkgs/pymetar-0.21.tar.gz
- md5sums = b41403f2efdd44f684cecf3f0aa1569d
+ depends = python
+ source = http://www.schwarzvogel.de/pkgs/pymetar-1.0.tar.gz
+ md5sums = 1b81f632b38a16e01f8969f630dd403a
pkgname = pymetar
diff --git a/PKGBUILD b/PKGBUILD
index 8ae65a81a4ef..8c723825d036 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,24 @@
#Maintainer: Jarek Sedlacek <jareksedlacek@gmail.com
pkgname=pymetar
-pkgver=0.21
+pkgver=1.0
pkgrel=1
pkgdesc="downloads the weather report for a given station ID, decodes it and the provides easy access to all the data found in the report"
arch=('i686' 'x86_64')
url="http://www.schwarzvogel.de/software-pymetar.shtml"
license=('GPL2')
-depends=('python2>=2.7' )
+depends=('python' )
source=("http://www.schwarzvogel.de/pkgs/$pkgname-$pkgver.tar.gz")
+md5sums=('1b81f632b38a16e01f8969f630dd403a')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python2 setup.py build
- sed -i 's/\/usr\/bin\/python -tt/\/usr\/bin\/env python2/' bin/pymetar
+ python setup.py build
}
package(){
cd "${srcdir}/${pkgname}-${pkgver}"
- install -m0755 -d ${pkgdir}/usr/{bin,lib/python2.7/site-packages,share/${pkgname}}
- chmod 0755 ${pkgdir}/usr/bin/
- install -m0644 -D PKG-INFO ${pkgdir}/usr/lib/python2.7/site-packages/${pkgname}-${pkgver}-py2.6.egg-info
- install -m0644 -D build/lib/pymetar.py ${pkgdir}/usr/lib/python2.7/site-packages/
- install -m0644 -D README librarydoc.txt ${pkgdir}/usr/share/${pkgname}
- install -m0755 -D bin/pymetar $pkgdir/usr/bin/
-
+ python setup.py install --prefix=/usr --root="$pkgdir"
}
# vim:set ts=2 sw=2 et:
-md5sums=('b41403f2efdd44f684cecf3f0aa1569d')