summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoodos2021-01-28 14:04:00 +0530
committerCoodos2021-01-28 14:04:00 +0530
commit5165093904fd8ad26342cb5434c3d67ac06cca35 (patch)
tree0e420d7479566b3cf7b6fee750112128345b30ae
parent4d05355f4d70ea1c04e9dd8b498dce0f69407663 (diff)
downloadaur-5165093904fd8ad26342cb5434c3d67ac06cca35.tar.gz
fixed timer
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--pymodoro1
-rw-r--r--pymodoro.py2
4 files changed, 4 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71d7b3078f3e..54db8062aacc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,7 @@ pkgbase = pymodoro
depends = dunst
depends = python3
source = pymodoro.py
- source = pymodoro
- sha256sums = 20e03acfafae79ee159115d2eb7503a808a8815c38a35a9ec8f94225e174efb2
- sha256sums = f5f0a9342159efc22fe201bf35ddbd7239eaefcf8c0406af137644106d7e1469
+ md5sums = 56e5be3fe6df013686297c4794649ff7
pkgname = pymodoro
diff --git a/PKGBUILD b/PKGBUILD
index 0ce52190e508..ec922db6d8d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,19 +10,12 @@ depends=('alsa-utils'
)
url="https://github.com/coodos/pymodoro/"
-source=('pymodoro.py'
- 'pymodoro'
-)
-
-sha256sums=('20e03acfafae79ee159115d2eb7503a808a8815c38a35a9ec8f94225e174efb2'
- 'f5f0a9342159efc22fe201bf35ddbd7239eaefcf8c0406af137644106d7e1469'
-)
-
+source=('pymodoro.py')
+md5sums=('56e5be3fe6df013686297c4794649ff7')
prepare () {
sudo pip install pyinstaller
pyinstaller --onefile pymodoro.py
cd ./dist/
- rm ../pymodoro
mv pymodoro ../
}
diff --git a/pymodoro b/pymodoro
deleted file mode 100644
index 0b7b2cd5bcc2..000000000000
--- a/pymodoro
+++ /dev/null
@@ -1 +0,0 @@
-Dummy pymodoro file
diff --git a/pymodoro.py b/pymodoro.py
index 326641c69f96..3e4e3f1f454f 100644
--- a/pymodoro.py
+++ b/pymodoro.py
@@ -14,7 +14,7 @@ class pomodoro():
counter = 1
while True:
if (counter % 2 == 1):
- print(f"Pomodoro Cycle {counter}")
+ print(f"Pomodoro Cycle {(counter % 2) + 1}")
codeUtils.timer(self.workTime, True)
elif (counter % 8 == 0):
codeUtils.timer(self.workTime, True)