summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-04-05 21:52:48 +0300
committerDrobot Viktor2019-04-05 21:52:48 +0300
commite561704da581f8bd8a0e41fe883b930a9fe5455d (patch)
tree5059fdcacb4ddaa73fb10d9b9c6196a79d67638b
downloadaur-e561704da581f8bd8a0e41fe883b930a9fe5455d.tar.gz
First release
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD56
-rw-r--r--apbstools_tcltk8.6.patch106
3 files changed, 192 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..936ce638aaa0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = pymol-python2
+ pkgdesc = Molecular visualization system on an Open Source foundation
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://pymol.org/
+ arch = x86_64
+ license = custom
+ makedepends = desktop-file-utils
+ makedepends = gendesk
+ makedepends = libmmtf
+ makedepends = msgpack-c
+ depends = freetype2
+ depends = glew
+ depends = glm
+ depends = glut
+ depends = python2-numpy
+ depends = tcsh
+ optdepends = python2-pmw: pmw based UI
+ optdepends = python2-pyqt5: Qt5 based UI
+ provides = pymol
+ conflicts = pymol
+ source = https://github.com/schrodinger/pymol-open-source/archive/v2.3.0.tar.gz
+ source = pymol.png::https://c.fsdn.com/allura/p/pymol/icon
+ source = apbstools_tcltk8.6.patch
+ sha512sums = e1dcea1c97bcd9045d3543e92902f240e6affbf61a38e8d2a0be04309e3dbabfe1a869847d1423b3151008978d4c305bbf3ce994fc9d453c0063ce020100c133
+ sha512sums = 39917c1dc80cd6a59e8f6b3ea49a59491eaf23d14e32ac264f6d71f33007f686deb6a66e50e7f20ef9df5337038e3572b018633c361460d5ee0c1d8f0a8259d1
+ sha512sums = 90fce6d3c4364cd775b44bdd9013a08f26392339bec40ecd749220b3d11391381f5b159734bdb2e2ac675fbc016a6a1b9c4cec2fa8c9c0226609a5f09b610b9c
+
+pkgname = pymol-python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dd82bf9ed56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: graysky
+# Contributor: Tomasz Żok <tomasz dot zok at gmail dot com>
+
+pkgname=pymol-python2
+_pkgname=pymol
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Molecular visualization system on an Open Source foundation (Python 2 version)"
+arch=('x86_64')
+url="https://pymol.org/"
+license=('custom')
+depends=('freetype2' 'glew' 'glm' 'glut' 'python2-numpy' 'tcsh')
+makedepends=('desktop-file-utils' 'gendesk' 'libmmtf' 'msgpack-c')
+optdepends=('python2-pmw: pmw based UI'
+ 'python2-pyqt5: Qt5 based UI')
+conflicts=('pymol')
+provides=('pymol')
+source=("https://github.com/schrodinger/pymol-open-source/archive/v${pkgver}.tar.gz"
+ ${_pkgname}.png::"https://c.fsdn.com/allura/p/pymol/icon"
+ "apbstools_tcltk8.6.patch")
+sha512sums=('e1dcea1c97bcd9045d3543e92902f240e6affbf61a38e8d2a0be04309e3dbabfe1a869847d1423b3151008978d4c305bbf3ce994fc9d453c0063ce020100c133'
+ '39917c1dc80cd6a59e8f6b3ea49a59491eaf23d14e32ac264f6d71f33007f686deb6a66e50e7f20ef9df5337038e3572b018633c361460d5ee0c1d8f0a8259d1'
+ '90fce6d3c4364cd775b44bdd9013a08f26392339bec40ecd749220b3d11391381f5b159734bdb2e2ac675fbc016a6a1b9c4cec2fa8c9c0226609a5f09b610b9c')
+
+prepare() {
+ # create desktop file
+ gendesk -f -n --pkgname "${_pkgname}" --pkgdesc "${pkgdesc}" \
+ --name="PyMOL Molecular Graphics System" \
+ --categories="Science;Chemistry"
+
+ # suppress non-zero exit code that breaks makepkg
+ sed -i '/sys.exit/ s,2,0,' "${srcdir}/${_pkgname}-open-source-${pkgver}/setup.py"
+ # change python to python2
+ find "${_pkgname}-open-source-${pkgver}" -name '*.py' -type f -exec \
+ sed -i 's|env python|env python2|g' {} \;
+ find "${_pkgname}-open-source-${pkgver}/test" -type f -exec \
+ sed -i 's|bin/python|bin/python2|g' {} \;
+ # fix FS#39526
+ cd "${srcdir}/${_pkgname}-open-source-${pkgver}"
+ patch -p0 -i "${srcdir}/apbstools_tcltk8.6.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-open-source-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-open-source-${pkgver}"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/pymol.desktop" "${pkgdir}/usr/share/applications/pymol.desktop"
+ install -Dm644 "${srcdir}/pymol.png" "${pkgdir}/usr/share/pixmaps/pymol.png"
+}
diff --git a/apbstools_tcltk8.6.patch b/apbstools_tcltk8.6.patch
new file mode 100644
index 000000000000..f60b5c78a69a
--- /dev/null
+++ b/apbstools_tcltk8.6.patch
@@ -0,0 +1,106 @@
+--- modules/pmg_tk/startup/apbs_tools.py.orig 2014-05-14 01:07:32.000000000 +0400
++++ modules/pmg_tk/startup/apbs_tools.py 2014-05-14 01:15:35.090032827 +0400
+@@ -612,7 +612,8 @@
+ # Set up the Main page
+ page = self.notebook.add('Main')
+ group = Pmw.Group(page,tag_text='Main options')
+- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
+ self.selection = Pmw.EntryField(group.interior(),
+ labelpos='w',
+ label_text='Selection to use: ',
+@@ -856,7 +864,8 @@
+ page.grid_columnconfigure(5,weight=1)
+ page = self.notebook.add('Program Locations')
+ group = Pmw.Group(page,tag_text='Locations')
+- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
+ def quickFileValidation(s):
+ if s == '': return Pmw.PARTIAL
+ elif os.path.isfile(s): return Pmw.OK
+@@ -955,7 +964,8 @@
+
+ page = self.notebook.add('Temp File Locations')
+ group = Pmw.Group(page,tag_text='Locations')
+- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
+ self.pymol_generated_pqr_filename = Pmw.EntryField(group.interior(),
+ labelpos = 'w',
+ label_pyclass = FileDialogButtonClassFactory.get(self.setPymolGeneratedPqrFilename),
+@@ -1003,17 +1013,20 @@
+ page = self.notebook.add('Visualization (1)')
+ group = VisualizationGroup(page,tag_text='Visualization',visgroup_num=1)
+ self.visualization_group_1 = group
+- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
+
+ page = self.notebook.add('Visualization (2)')
+ group = VisualizationGroup(page,tag_text='Visualization',visgroup_num=2)
+ self.visualization_group_2 = group
+- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
+
+ # Create a couple of other empty pages
+ page = self.notebook.add('About')
+ group = Pmw.Group(page, tag_text='About PyMOL APBS Tools')
+- group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ #group.pack(fill = 'both', expand = 1, padx = 10, pady = 5)
++ group.grid(padx = 10, pady = 5, sticky=(N, S, E, W))
+ text = """This plugin integrates PyMOL (http://PyMOL.org/) with APBS (http://www.poissonboltzmann.org/apbs/).
+
+ Documentation may be found at
+@@ -2271,7 +2284,8 @@
+ self.update_buttonbox = Pmw.ButtonBox(self.mm_group.interior(), padx=0)
+ self.update_buttonbox.pack(side=LEFT)
+ self.update_buttonbox.add('Update',command=self.refresh)
+- self.mm_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
++ #self.mm_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
++ self.mm_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
+
+ self.ms_group = Pmw.Group(self.interior(),tag_text='Molecular Surface')
+ self.ms_buttonbox = Pmw.ButtonBox(self.ms_group.interior(), padx=0)
+@@ -2322,7 +2336,8 @@
+ bars = (self.mol_surf_low,self.mol_surf_middle,self.mol_surf_high)
+ Pmw.alignlabels(bars)
+ for bar in bars: bar.pack(side=LEFT)
+- self.ms_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
++ #self.ms_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
++ self.ms_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
+
+ self.fl_group = Pmw.Group(self.interior(),tag_text='Field Lines')
+ self.fl_buttonbox = Pmw.ButtonBox(self.fl_group.interior(), padx=0)
+@@ -2337,7 +2352,8 @@
+ text = """Follows same coloring as surface.""",
+ )
+ label.pack()
+- self.fl_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
++ #self.fl_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=TOP)
++ self.fl_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
+
+ self.pi_group = Pmw.Group(self.interior(),tag_text='Positive Isosurface')
+ self.pi_buttonbox = Pmw.ButtonBox(self.pi_group.interior(), padx=0)
+@@ -2356,7 +2372,8 @@
+ entryfield_validate = {'validator' : 'real', 'min':0}
+ )
+ self.pos_surf_val.pack(side=LEFT)
+- self.pi_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
++ #self.pi_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
++ self.pi_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
+
+ self.ni_group = Pmw.Group(self.interior(),tag_text='Negative Isosurface')
+ self.ni_buttonbox = Pmw.ButtonBox(self.ni_group.interior(), padx=0)
+@@ -2375,7 +2392,8 @@
+ entryfield_validate = {'validator' : 'real', 'max':0}
+ )
+ self.neg_surf_val.pack(side=LEFT)
+- self.ni_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
++ #self.ni_group.pack(fill = 'both', expand = 1, padx = 4, pady = 5, side=LEFT)
++ self.ni_group.grid(padx = 4, pady = 5, sticky=(N, S, E, W))
+
+
+