summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorinvik2018-02-03 11:19:20 +0100
committerinvik2018-02-03 11:19:20 +0100
commit139ba78800ab8504e0837741a406abc3cf7a6df4 (patch)
tree55c648c4a5517b50b2a0cef2bcce169873e65c33
parenta1cd2d2596c9f3337ec2086e4303a89478b52647 (diff)
downloadaur-139ba78800ab8504e0837741a406abc3cf7a6df4.tar.gz
Switched source to conda package for smaller size
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 33 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34ea929d3639..1ead4d42c891 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pymol2
- pkgdesc = Molecular visualization system on an Open Source foundation with PyQt interface
+ pkgdesc = Molecular visualization system on an Open Source foundation with modern PyQt interface. Includes Python 2 & 3 Bindings.
pkgver = 2.0.7
- pkgrel = 2
+ pkgrel = 3
url = https://pymol.org/2/
arch = x86_64
license = Commercial
@@ -10,13 +10,18 @@ pkgbase = pymol2
depends = glew
depends = glut
depends = libgl
- provides = pymol2
- conflicts = pymol2
- noextract = PyMOL-2.0.7_0-Linux-x86_64.tar.bz2
+ depends = libxml2
+ depends = python-numpy
+ depends = python-pmw
+ depends = python-pyqt5
+ conflicts = pymol
options = !strip
- source = https://pymol.org/installers/PyMOL-2.0.7_0-Linux-x86_64.tar.bz2
- sha1sums = 967495b4810f7bf72f914e0f1a3648a4614f258d
- sha256sums = c7fb43f512882f250d006d0cb6eda70951d75671c411ca0fd665321820316bd4
+ source = https://anaconda.org/schrodinger/pymol/2.0.7/download/linux-64/pymol-2.0.7-py27_0.tar.bz2
+ source = https://anaconda.org/schrodinger/pymol/2.0.7/download/linux-64/pymol-2.0.7-py36_0.tar.bz2
+ sha1sums = 8f23550513b341fad8a5753aa17facf755414684
+ sha1sums = aefc79f370cb550a6a91c6e2b14378498eb111f5
+ sha256sums = ab828a456a9e82f137b753e5d66ff3510663c24d220fb731b58b0bddf5e819b5
+ sha256sums = 64e7980ed33a13bd4ee1b18455e32d90089e259b0c26662519b0d41b7a4ae753
pkgname = pymol2
diff --git a/PKGBUILD b/PKGBUILD
index d27302a67f91..af6501b061ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,36 @@
# Maintainer: Ricardo Rodríguez Schmidt <ricrogz at gmail.com>
-pkgname='pymol2'
-_pkgname='pymol2'
+pkgname=pymol2
pkgver='2.0.7'
-pkgrel='2'
-pkgdesc='Molecular visualization system on an Open Source foundation with PyQt interface'
+pkgrel='3'
+pkgdesc='Molecular visualization system on an Open Source foundation with modern PyQt interface. Includes Python 2 & 3 Bindings.'
arch=('x86_64')
options=(!strip)
url='https://pymol.org/2/'
license=('Commercial')
-depends=('glew' 'glut' 'libgl')
+depends=('glew' 'glut' 'libgl' 'libxml2' 'python-numpy' 'python-pmw' 'python-pyqt5')
makedepends=('desktop-file-utils' 'gendesk')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("https://pymol.org/installers/PyMOL-${pkgver}_0-Linux-${arch}.tar.bz2")
-sha1sums=('967495b4810f7bf72f914e0f1a3648a4614f258d')
-sha256sums=('c7fb43f512882f250d006d0cb6eda70951d75671c411ca0fd665321820316bd4')
-noextract=("PyMOL-${pkgver}_0-Linux-${arch}.tar.bz2")
+conflicts=(pymol)
+source=("https://anaconda.org/schrodinger/pymol/${pkgver}/download/linux-64/pymol-${pkgver}-py27_0.tar.bz2"
+"https://anaconda.org/schrodinger/pymol/${pkgver}/download/linux-64/pymol-${pkgver}-py36_0.tar.bz2")
+sha1sums=('8f23550513b341fad8a5753aa17facf755414684'
+ 'aefc79f370cb550a6a91c6e2b14378498eb111f5')
+sha256sums=('ab828a456a9e82f137b753e5d66ff3510663c24d220fb731b58b0bddf5e819b5'
+ '64e7980ed33a13bd4ee1b18455e32d90089e259b0c26662519b0d41b7a4ae753')
+
build() {
# create desktop file
- gendesk -f -n --pkgname "${pkgname}" --pkgdesc "${pkgdesc}" \
- --name="PyMOL2 Molecular Graphics System" \
- --categories="Science;Chemistry"
+ gendesk -f -n --pkgname "${pkgname}" --pkgdesc "${pkgdesc}" --name="PyMOL2 Molecular Graphics System" --categories="Science;Chemistry"
- mkdir -p "${srcdir}/opt/${pkgname}"
- bsdtar --strip-components 1 -jxf PyMOL-${pkgver}_0-Linux-${arch}.tar.bz2 \
- -C "${srcdir}/opt/${pkgname}"
+ mv "${srcdir}/bin/pymol" "${srcdir}/bin/pymol2"
}
package() {
- mkdir -p "${pkgdir}/usr/bin/"
-
- rsync -rtl "${srcdir}/opt" "${pkgdir}"
+ mkdir -p "${pkgdir}/usr"
- ln -s "/opt/${pkgname}/bin/pymol" \
- "${pkgdir}/usr/bin/${pkgname}"
+ rsync -rtl "${srcdir}/bin" "${pkgdir}/usr"
+ rsync -rtl "${srcdir}/lib" "${pkgdir}/usr"
+ rsync -rtl "${srcdir}/share" "${pkgdir}/usr"
install -Dm644 "${srcdir}/pymol2.desktop" "${pkgdir}/usr/share/applications/pymol2.desktop"
- install -Dm644 "${srcdir}/opt/${pkgname}/share/pymol/data/pymol/icons/icon2_32x32.png" "${pkgdir}/usr/share/pixmaps/pymol2.png"
-}
+ install -Dm644 "${srcdir}/share/pymol/data/pymol/icons/icon2_32x32.png" "${pkgdir}/usr/share/pixmaps/pymol2.png"
+} \ No newline at end of file