summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorinvik2018-02-05 12:45:21 +0100
committerinvik2018-02-05 12:45:21 +0100
commite0e3b60c71cd182c2e993715409bfd8c60ffe8a9 (patch)
tree1d712c7428c6ab595884643f75368898153600a2
parent139ba78800ab8504e0837741a406abc3cf7a6df4 (diff)
downloadaur-e0e3b60c71cd182c2e993715409bfd8c60ffe8a9.tar.gz
Post install message to run Open Source Version; povray as optdepends
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--pymol2.install17
3 files changed, 22 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ead4d42c891..92eb6bc0e4ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = pymol2
pkgver = 2.0.7
pkgrel = 3
url = https://pymol.org/2/
+ install = pymol2.install
arch = x86_64
license = Commercial
makedepends = desktop-file-utils
@@ -14,6 +15,7 @@ pkgbase = pymol2
depends = python-numpy
depends = python-pmw
depends = python-pyqt5
+ optdepends = povray
conflicts = pymol
options = !strip
source = https://anaconda.org/schrodinger/pymol/2.0.7/download/linux-64/pymol-2.0.7-py27_0.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index af6501b061ce..458cda8754f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,12 @@ pkgver='2.0.7'
pkgrel='3'
pkgdesc='Molecular visualization system on an Open Source foundation with modern PyQt interface. Includes Python 2 & 3 Bindings.'
arch=('x86_64')
-options=(!strip)
url='https://pymol.org/2/'
license=('Commercial')
depends=('glew' 'glut' 'libgl' 'libxml2' 'python-numpy' 'python-pmw' 'python-pyqt5')
+optdepends=('povray')
+options=(!strip)
+install="${pkgname}.install"
makedepends=('desktop-file-utils' 'gendesk')
conflicts=(pymol)
source=("https://anaconda.org/schrodinger/pymol/${pkgver}/download/linux-64/pymol-${pkgver}-py27_0.tar.bz2"
diff --git a/pymol2.install b/pymol2.install
new file mode 100644
index 000000000000..1926cc943a8e
--- /dev/null
+++ b/pymol2.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo ""
+ echo " ====== "
+ echo " To use only the Open Source features in PyMOL2, you can use the \"-n\" option,"
+ echo " Or you can also add it to lines 28 and 34 /usr/bin/pymol2 to use it "
+ echo " automatically in every invocation, i.e. line 28 would become:"
+ echo " "
+ echo " exec "$python" -m pymol -n \"\$@\""
+ echo " "
+ echo " ====== "
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}
+