summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2016-05-31 18:58:59 +0200
committerStefan Tatschner2016-05-31 18:58:59 +0200
commitcbf2c035b75959d878cd278cd29433e6b5d5b297 (patch)
treeae2a10b88d1d32d2b018ed5c6cd969ccd1c0fdbd
parentfa628f6aa9a72abae689918edae262554c143ca6 (diff)
downloadaur-cbf2c035b75959d878cd278cd29433e6b5d5b297.tar.gz
upgpkg: pynote 2.0.0-1
upstream release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--pynote.install13
3 files changed, 25 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 257f3f4730ef..99e68423e6f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue May 31 16:59:05 UTC 2016
pkgbase = pynote
pkgdesc = Manage notes on the commandline
- pkgver = 1.0.0
- pkgrel = 3
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/rumpelsepp/pynote
install = pynote.install
arch = any
license = MIT
- makedepends = python-sphinx
- makedepends = python-setuptools
+ makedepends = asciidoctor
depends = python
- depends = python-plaintable
- depends = python-click
- depends = python-babel
- optdepends = python-pygments: synthax highlighting support
+ depends = python-tabulate
+ depends = python-arrow
provides = pynote
conflicts = pynote-docs
conflicts = pynote-git
conflicts = pynote-docs-git
- source = https://pypi.python.org/packages/source/p/pynote/pynote-1.0.0.tar.gz
- sha256sums = 6d4fe9d8234fcc1d09b4cd8d8def1c75745e02c895e2f8fe6e3c3987e3c02cbe
+ source = git+https://github.com/rumpelsepp/pynote#commit=abbbaacedc4a6825abc70ed7ec18305e105ffc63
+ sha256sums = SKIP
pkgname = pynote
diff --git a/PKGBUILD b/PKGBUILD
index 785966fa37c6..afaab68fe497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,30 @@
-# Maintainer: Stefan Tatschner <stefan@sevenbyte.org>
+# Maintainer: Stefan Tatschner <rumpelsepp@sevenbyte.org>
pkgname='pynote'
-pkgver=1.0.0
-pkgrel=3
+pkgver=2.0.0
+pkgrel=1
pkgdesc="Manage notes on the commandline"
arch=('any')
url="https://github.com/rumpelsepp/pynote"
license=('MIT')
provides=('pynote')
-depends=('python' 'python-plaintable' 'python-click' 'python-babel')
-optdepends=('python-pygments: synthax highlighting support')
-makedepends=('python-sphinx' 'python-setuptools')
+depends=('python' 'python-tabulate' 'python-arrow')
+makedepends=('asciidoctor')
conflicts=('pynote-docs' 'pynote-git' 'pynote-docs-git')
-source=("https://pypi.python.org/packages/source/p/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('6d4fe9d8234fcc1d09b4cd8d8def1c75745e02c895e2f8fe6e3c3987e3c02cbe')
+source=("git+https://github.com/rumpelsepp/pynote#commit=abbbaacedc4a6825abc70ed7ec18305e105ffc63")
+sha256sums=('SKIP')
install=pynote.install
build() {
- cd "${srcdir}/${pkgbase}-${pkgver}/docs"
+ cd "${srcdir}/${pkgname}/man"
make man
- make text
}
package() {
- cd "${srcdir}/${pkgbase}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
- mkdir -p ${pkgdir}/usr/share/man/man1/
- mkdir -p ${pkgdir}/usr/share/man/man5/
- mkdir -p ${pkgdir}/usr/share/doc/pynote/
+ install -D "man/note.1" "${pkgdir}/usr/share/man/man1/note.1"
+ install -D "man/noterc.5" "${pkgdir}/usr/share/man/man5/noterc.5"
- cp -ra "docs/man/note.1" "${pkgdir}/usr/share/man/man1/note.1"
- cp -ra "docs/man/noterc.5" "${pkgdir}/usr/share/man/man5/noterc.5"
- cp -ra docs/text/* "${pkgdir}/usr/share/doc/pynote/"
-
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}
diff --git a/pynote.install b/pynote.install
index 5c6f40e49f62..89dff9a2dc4f 100644
--- a/pynote.install
+++ b/pynote.install
@@ -1,11 +1,6 @@
-post_install() {
- echo "Do not forget to check the release notes!"
- echo "https://pynote.readthedocs.org/en/latest/changelog.html"
-}
-
post_upgrade() {
- echo "Do not forget to check the release notes!"
- echo "https://pynote.readthedocs.org/en/latest/changelog.html"
- echo "You find upgrade instructions here:"
- echo "https://pynote.readthedocs.org/en/latest/faq.html#upgrading-from-0-2-to-1-0"
+ echo "Pynote 2.0.0 is a complete rewrite!"
+ echo "Some file locations and config values have changed."
+ echo "Please copy ~/.noterc to ~/.config/note/noterc!"
+ echo "Additional information can be found in the manpage noterc(5)."
}