summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2015-06-09 22:53:41 +0200
committerStefan Tatschner2015-06-09 22:53:41 +0200
commitfa628f6aa9a72abae689918edae262554c143ca6 (patch)
tree402ab0a992e6f4251b6672be71af7d0bee584e0a
downloadaur-fa628f6aa9a72abae689918edae262554c143ca6.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
-rw-r--r--pynote.install11
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..257f3f4730ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pynote
+ pkgdesc = Manage notes on the commandline
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = https://github.com/rumpelsepp/pynote
+ install = pynote.install
+ arch = any
+ license = MIT
+ makedepends = python-sphinx
+ makedepends = python-setuptools
+ depends = python
+ depends = python-plaintable
+ depends = python-click
+ depends = python-babel
+ optdepends = python-pygments: synthax highlighting support
+ provides = pynote
+ conflicts = pynote-docs
+ conflicts = pynote-git
+ conflicts = pynote-docs-git
+ source = https://pypi.python.org/packages/source/p/pynote/pynote-1.0.0.tar.gz
+ sha256sums = 6d4fe9d8234fcc1d09b4cd8d8def1c75745e02c895e2f8fe6e3c3987e3c02cbe
+
+pkgname = pynote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..785966fa37c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Stefan Tatschner <stefan@sevenbyte.org>
+
+pkgname='pynote'
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="Manage notes on the commandline"
+arch=('any')
+url="https://github.com/rumpelsepp/pynote"
+license=('MIT')
+provides=('pynote')
+depends=('python' 'python-plaintable' 'python-click' 'python-babel')
+optdepends=('python-pygments: synthax highlighting support')
+makedepends=('python-sphinx' 'python-setuptools')
+conflicts=('pynote-docs' 'pynote-git' 'pynote-docs-git')
+source=("https://pypi.python.org/packages/source/p/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('6d4fe9d8234fcc1d09b4cd8d8def1c75745e02c895e2f8fe6e3c3987e3c02cbe')
+install=pynote.install
+
+build() {
+ cd "${srcdir}/${pkgbase}-${pkgver}/docs"
+ make man
+ make text
+}
+
+package() {
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+
+ mkdir -p ${pkgdir}/usr/share/man/man1/
+ mkdir -p ${pkgdir}/usr/share/man/man5/
+ mkdir -p ${pkgdir}/usr/share/doc/pynote/
+
+ cp -ra "docs/man/note.1" "${pkgdir}/usr/share/man/man1/note.1"
+ cp -ra "docs/man/noterc.5" "${pkgdir}/usr/share/man/man5/noterc.5"
+ cp -ra docs/text/* "${pkgdir}/usr/share/doc/pynote/"
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
diff --git a/pynote.install b/pynote.install
new file mode 100644
index 000000000000..5c6f40e49f62
--- /dev/null
+++ b/pynote.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "Do not forget to check the release notes!"
+ echo "https://pynote.readthedocs.org/en/latest/changelog.html"
+}
+
+post_upgrade() {
+ echo "Do not forget to check the release notes!"
+ echo "https://pynote.readthedocs.org/en/latest/changelog.html"
+ echo "You find upgrade instructions here:"
+ echo "https://pynote.readthedocs.org/en/latest/faq.html#upgrading-from-0-2-to-1-0"
+}