summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTudor Roman2018-07-10 23:06:26 +0300
committerTudor Roman2018-07-10 23:06:26 +0300
commitad638739bc32f97d0e62d8fe5a2f392c6db2fc07 (patch)
tree897bbe383f66a070295923b5b62dde3dc5e41c81
downloadaur-ad638739bc32f97d0e62d8fe5a2f392c6db2fc07.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be84fbf90a08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pynotifyd
+ pkgdesc = Simple freedesktop notification server
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/ricede/pynotifyd
+ arch = any
+ license = ISC
+ makedepends = git
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-gobject
+ depends = python-dbus
+ depends = dbus-glib
+ source = https://files.pythonhosted.org/packages/source/p/pynotifyd/pynotifyd-0.0.2.tar.gz
+ md5sums = 65c08468c85e881dba948114f0fdb921
+
+pkgname = pynotifyd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49139bd799f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Tudor Roman <tudurom@gmail.com>
+
+pkgname=pynotifyd
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Simple freedesktop notification server"
+arch=("any")
+url="https://github.com/ricede/pynotifyd"
+license=('ISC')
+depends=("python-gobject" "python-dbus" "dbus-glib")
+makedepends=("git" "python" "python-setuptools")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=("65c08468c85e881dba948114f0fdb921")
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root "$pkgdir"
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}