summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:08:56 +0200
committerM0Rf302015-06-17 16:08:56 +0200
commitf7e68cccf824a92474bedd9d21dcea177ceb524e (patch)
treed62b0e3a0b0f8a2db4fd92c33eef6e5ad4865f97
downloadaur-f7e68cccf824a92474bedd9d21dcea177ceb524e.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--ntkd.service12
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6da1ca412051
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pyntk-svn
+ pkgdesc = Netsukuku: An experimental peer-to-peer wireless routing system, written in Python
+ pkgver = 1185
+ pkgrel = 1
+ url = http://netsukuku.freaknet.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = subversion
+ makedepends = python2-distribute
+ depends = stackless-python2
+ provides = pyntk
+ source = pyntk::svn+https://github.com/venugopalk/netsukuku
+ source = ntkd.service
+ md5sums = SKIP
+ md5sums = 2afcefb8d01dfc1f89873f04db67e098
+
+pkgname = pyntk-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd6c666e08ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: M0Rf30
+
+pkgname=pyntk-svn
+pkgver=1185
+pkgrel=1
+pkgdesc="Netsukuku: An experimental peer-to-peer wireless routing system, written in Python"
+arch=('i686' 'x86_64')
+url="http://netsukuku.freaknet.org"
+source=('ntkd.rc'
+ 'ntkd.service')
+license=('GPL')
+depends=('stackless-python2')
+makedepends=('subversion' 'python2-distribute')
+provides=('pyntk')
+source=("pyntk::svn+https://github.com/venugopalk/netsukuku"
+ ntkd.service)
+
+package() {
+ cd pyntk/trunk/pyntk
+ python2 setup.py install --root=$pkgdir
+ install -Dm755 ${srcdir}/ntkd.service ${pkgdir}/usr/lib/systemd/system/ntkd.service
+}
+
+pkgver() {
+ cd pyntk
+ svnversion | tr -d [A-z]
+}
+
+md5sums=('SKIP'
+ '2afcefb8d01dfc1f89873f04db67e098')
diff --git a/ntkd.service b/ntkd.service
new file mode 100644
index 000000000000..2869dab20378
--- /dev/null
+++ b/ntkd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Netsukuku
+After=network.target
+
+[Service]
+Type=forking
+User=root
+ExecStart=/usr/bin/ntkd
+PIDFile=/var/run/ntkd.pid
+
+[Install]
+WantedBy=multi-user.target