summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgileri2016-02-14 22:59:58 +0100
committergileri2016-02-14 22:59:58 +0100
commit8921c16c0bd5a941ce825abcd1da6e95a26b484b (patch)
tree4d67b5366a8cbcf18989c30cadb5daa2f2206417
downloadaur-8921c16c0bd5a941ce825abcd1da6e95a26b484b.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfa6883e1010
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.0.0
+# Sun Feb 14 21:59:41 UTC 2016
+pkgbase = pyosmium-git
+ pkgdesc = Python bindings for libosmium
+ pkgver = v2.6.0.r2.gc7604fd
+ pkgrel = 1
+ url = http://osmcode.org/pyosmium
+ arch = x86_64
+ arch = i686
+ license = custom
+ depends = boost-libs
+ conflicts = libosmium
+ source = pyosmium::git+https://github.com/osmcode/pyosmium.git
+ md5sums = SKIP
+
+pkgname = pyosmium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d647613a0e50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: gileri <twiked at gmail d(0)t com>
+pkgname=pyosmium-git
+pkgver=v2.6.0.r2.gc7604fd
+pkgrel=1
+pkgdesc="Python bindings for libosmium"
+url="http://osmcode.org/pyosmium"
+arch=('x86_64' 'i686')
+license=('custom')
+depends=('boost-libs')
+optdepends=()
+conflicts=(libosmium)
+source=('pyosmium::git+https://github.com/osmcode/pyosmium.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd pyosmium
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/pyosmium"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/pyosmium"
+ python setup.py install --prefix="${pkgdir}/usr/"
+ ls
+ install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}