summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2015-06-09 13:14:54 +0200
committerValHue2015-06-09 13:14:54 +0200
commit7b104b26c5ab24b91285f087050ba5a3a149566a (patch)
tree3641723fa672fb12e5d9631835329bdd012c7e8c
downloadaur-7b104b26c5ab24b91285f087050ba5a3a149566a.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
-rw-r--r--pypar2.install11
4 files changed, 96 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..b70db1aa9ba2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = pypar2
+ pkgdesc = Graphical frontend (PyGTK) for the Linux par2 utility
+ pkgver = 1.4
+ pkgrel = 7
+ url = http://pypar2.silent-blade.org/
+ install = pypar2.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = libglade
+ depends = par2cmdline
+ depends = pygtk
+ depends = vte
+ source = http://pypar2.silent-blade.org/uploads/Main/pypar2-1.4.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/p/pypar2/pypar2_1.4-7.debian.tar.xz
+
+pkgname = pypar2
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4f38040c2b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pypar2
+ pkgdesc = Graphical frontend (PyGTK) for the Linux par2 utility
+ pkgver = 1.4
+ pkgrel = 7
+ url = http://pypar2.silent-blade.org/
+ install = pypar2.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = libglade
+ depends = par2cmdline
+ depends = pygtk
+ depends = vte
+ source = http://pypar2.silent-blade.org/uploads/Main/pypar2-1.4.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/p/pypar2/pypar2_1.4-7.debian.tar.xz
+ md5sums = d77ea7c0ff88209d994c5723c98d00a5
+ md5sums = 90908545d62843894b0fc59ddcb2b582
+
+pkgname = pypar2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f6cefe9b605
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: shamrok <szamrok at gmail dot com>
+
+pkgname=pypar2
+pkgver=1.4
+pkgrel=7
+pkgdesc="Graphical frontend (PyGTK) for the Linux par2 utility"
+url="http://pypar2.silent-blade.org/"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('desktop-file-utils' 'libglade' 'par2cmdline' 'pygtk' 'vte')
+install="${pkgname}.install"
+source=("http://pypar2.silent-blade.org/uploads/Main/${pkgname}-${pkgver}.tar.gz"
+ "http://ftp.de.debian.org/debian/pool/main/p/${pkgname}/${pkgname}_1.4-7.debian.tar.xz")
+md5sums=('d77ea7c0ff88209d994c5723c98d00a5'
+ '90908545d62843894b0fc59ddcb2b582')
+
+build() {
+ cd "${srcdir}/PyPar2-${pkgver}"
+
+ # python2 fix
+ sed -i 's_PYTHON ?= python_PYTHON ?= python2_' Makefile
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ ### Fixing errors ###
+ cd "${srcdir}/debian/patches"
+
+ # PyXMLSec fix
+ patch ${srcdir}/PyPar2-1.4/src/prefsManager.py no_pyxml.patch
+
+ # typeToolBox fix
+ patch ${srcdir}/PyPar2-1.4/src/typeToolBox.py typeorder.patch
+}
+
+package() {
+ cd "${srcdir}/PyPar2-${pkgver}"
+ make prefix=${pkgdir}/usr install
+ rm ${pkgdir}/usr/bin/pypar2
+ ln -s /usr/share/pypar2/src/main.py ${pkgdir}/usr/bin/pypar2
+}
diff --git a/pypar2.install b/pypar2.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/pypar2.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}