summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2023-03-03 12:35:53 +0100
committerD3SOX2023-03-03 12:35:53 +0100
commit89d79d1b8b980355ac827213f9a315b361a2e71c (patch)
tree4032f467198a2f4e72f5bad8473bad8e607c9daf
downloadaur-89d79d1b8b980355ac827213f9a315b361a2e71c.tar.gz
init package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0a8e31f1cd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pypeek-git
+ pkgdesc = Simple animated GIF screen recorder with an easy to use interface
+ pkgver = r1540.4e0fce8
+ pkgrel = 1
+ url = https://github.com/firatkiral/pypeek
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-hatchling
+ depends = python
+ depends = python-requests
+ depends = pyside6
+ provides = pypeek
+ conflicts = pypeek
+ source = git+https://github.com/firatkiral/pypeek.git
+ sha256sums = SKIP
+
+pkgname = pypeek-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b11de702b72f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Nico <d3sox at protonmail dot com>
+pkgname=pypeek-git
+pkgver=r1540.4e0fce8
+pkgrel=1
+pkgdesc="Simple animated GIF screen recorder with an easy to use interface"
+arch=(any)
+url="https://github.com/firatkiral/pypeek"
+license=('GPL3')
+depends=('python' 'python-requests' 'pyside6')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-hatchling')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ #python -m venv env
+ #source env/bin/activate
+ #pip install -r data/req.txt
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ echo 'test'
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ #make DESTDIR="$pkgdir/" install
+}