summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfdev312024-05-12 19:20:47 +0200
committerfdev312024-05-12 19:20:47 +0200
commit96aba88e8ef7c55fd37b6d4ba6a35880365ea530 (patch)
treee452d2b04c510a329aae5ec2db9be6cc31f65d9d
parent44c75cc661283d5f11ba6c766558199f83c5af71 (diff)
downloadaur-96aba88e8ef7c55fd37b6d4ba6a35880365ea530.tar.gz
simplify release PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d07f98cc212c..78c71a2e117a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = pyprland
pkgdesc = Customize your Hyprland with scratchpads, menus, easy monitor layout and other extensions
pkgver = 2.2.20
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fdev31/pyprland
arch = any
license = MIT
- makedepends = git
makedepends = python-build
makedepends = python-installer
makedepends = python-poetry
depends = python
depends = python-aiofiles
+ depends = hyprland
provides = pyprland
conflicts = pyprland
- source = git+https://github.com/fdev31/pyprland.git#tag=2.2.20
- md5sums = SKIP
+ source = pyprland-2.2.20.tar.gz::https://github.com/fdev31/pyprland/archive/refs/tags/2.2.20.tar.gz
+ sha256sums = 76e71dd7da5cb5e3b3fd5d6ef8375f5eb4588f07a3c488813c0bf0b72c624ea5
pkgname = pyprland
diff --git a/PKGBUILD b/PKGBUILD
index b78436942cd7..aeee61e919ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,32 @@
# Contributor: Fabien Devaux <fdev31@gmail.com>
pkgname=pyprland
pkgver=2.2.20
-pkgrel=1
+pkgrel=2
pkgdesc="Customize your Hyprland with scratchpads, menus, easy monitor layout and other extensions"
arch=(any)
url="https://github.com/fdev31/pyprland"
license=('MIT')
groups=()
-depends=('python' 'python-aiofiles')
-makedepends=('git' 'python-build' 'python-installer' 'python-poetry')
+depends=('python' 'python-aiofiles' 'hyprland')
+makedepends=('python-build' 'python-installer' 'python-poetry')
provides=("${pkgname}")
conflicts=("${pkgname}")
replaces=()
backup=()
options=()
-install=
-source=(git+"https://github.com/fdev31/pyprland.git#tag=${pkgver}")
noextract=()
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git checkout ${pkgver}
- printf "%s" "$(git describe --tags)"
-}
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('76e71dd7da5cb5e3b3fd5d6ef8375f5eb4588f07a3c488813c0bf0b72c624ea5')
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd $pkgname-$pkgver
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd $pkgname-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm0644 "scripts/completions/pypr.bash" "$pkgdir/usr/share/bash-completion/completions/pypr"
install -Dm0644 "scripts/completions/pypr.zsh" "$pkgdir/usr/share/zsh/site-functions/_pypr"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}