summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfdev312025-03-23 15:59:05 +0100
committerfdev312025-03-23 15:59:05 +0100
commitb01d939d2c6c1183b33b5286abb840648d223921 (patch)
treea752de03c885bcc47f0facff8a14be3d17427465
parenteb1c4d4f145644e920d717d83b298641a64405dc (diff)
downloadaur-b01d939d2c6c1183b33b5286abb840648d223921.tar.gz
switch to the C client
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index feb6137cabe7..fc9d1e8a621e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyprland-git
pkgdesc = Easy scratchpads, menus, smart monitor placement and more hyprland tweaks (GIT version)
pkgver = r1424.5293179
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/fdev31/pyprland
arch = any
license = MIT
@@ -9,7 +9,6 @@ pkgbase = pyprland-git
makedepends = python-build
makedepends = python-installer
makedepends = python-poetry
- makedepends = go
depends = python
depends = python-aiofiles
provides = pyprland
diff --git a/PKGBUILD b/PKGBUILD
index bd8ff2d55f17..f5bfa2de7565 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Fabien Devaux <fdev31@gmail.com>
pkgname=pyprland-git
pkgver=r1424.5293179
-pkgrel=2
+pkgrel=3
pkgdesc="Easy scratchpads, menus, smart monitor placement and more hyprland tweaks (GIT version)"
arch=(any)
url="https://github.com/fdev31/pyprland"
license=('MIT')
groups=()
depends=('python' 'python-aiofiles')
-makedepends=('git' 'python-build' 'python-installer' 'python-poetry' 'go')
+makedepends=('git' 'python-build' 'python-installer' 'python-poetry')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -29,7 +29,7 @@ build() {
cd "$srcdir/${pkgname%-git}"
python -m build --wheel --no-isolation
cd client
- go build -ldflags "-s -w" pypr-client.go
+ ${CC:-gcc} -o pypr-client pypr-client.c
}
package() {