summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-10-03 15:21:10 +0200
committerPellegrino Prevete2021-10-03 15:21:10 +0200
commit1864ccd330805e6a950721a070c072f1ef006a72 (patch)
tree0729cfe1c10d6e33b823cda796eb46f2c0ddc676
downloadaur-1864ccd330805e6a950721a070c072f1ef006a72.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e5ce487e968
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pypropack
+ pkgdesc = A python wrapper for the PROPACK library
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/jakevdp/pypropack
+ arch = any
+ license = BSD
+ depends = python
+ source = git+https://github.com/jakevdp/pypropack
+ sha512sums = SKIP
+
+pkgname = pypropack
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66d36211237b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+pkgname=pypropack
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='A python wrapper for the PROPACK library '
+url="https://github.com/jakevdp/pypropack"
+license=('BSD')
+arch=('any')
+depends=('python')
+makedepends=()
+source=("git+$url")
+sha512sums=('SKIP')
+
+package() {
+ cd $pkgname
+ python3 setup.py install --root="${pkgdir}" --optimize=1
+}