summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2019-01-29 12:57:59 +0100
committerDaniel Milde2019-01-29 12:57:59 +0100
commit439b6d43ab11d2e4a3a5130fd1e716ea59ed3423 (patch)
treee916d5611728c9c7eda1382ef8e6ede52c967b91
parentf1d500bc39e1aaacf90244b4fbae38eae1332eba (diff)
downloadaur-439b6d43ab11d2e4a3a5130fd1e716ea59ed3423.tar.gz
1.12.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 732c158a79f4..732a9c002ed9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
+# Generated by mksrcinfo v8
+# Út led 29 11:57:46 UTC 2019
pkgbase = pypy-six
pkgdesc = Python 2 and 3 compatibility utilities (build for pypy)
- pkgver = 1.10.0
+ pkgver = 1.12.0
pkgrel = 1
url = http://pypi.python.org/pypi/six/
arch = any
license = MIT
- makedepends = pypy
- makedepends = pypy3
- source = http://pypi.python.org/packages/source/s/six/six-1.10.0.tar.gz
- md5sums = 34eed507548117b2ab523ab14b2f8b55
+ makedepends = pypy-setuptools
+ makedepends = pypy3-setuptools
+ source = https://pypi.io/packages/source/s/six/six-1.12.0.tar.gz
+ sha512sums = 937728372edf1e0ac13bbd706723d0de35e015c30d0ae41f789c5ed2e3669bb0db70cdc6e036ec2d437a6c4aa0d5d1e727b6d09ac34cca7e4e92e5d3b4775151
pkgname = pypy-six
depends = pypy
diff --git a/PKGBUILD b/PKGBUILD
index fb3a1aaf5aa1..576c76e219cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,24 @@
-# Maintainer: Markus Kitsinger (SwooshyCueb) <root@swooshalicio.us>
+# Maintainer: Daniel Milde <daniel@milde.cz>
# Contributer: Jelle van der Waa <jelle@vdwaa.nl>
# Contributer: Allan McRae <allan@archlinux.org>
pkgbase=pypy-six
pkgname=('pypy-six' 'pypy3-six')
-pkgver=1.10.0
+pkgver=1.12.0
pkgrel=1
pkgdesc="Python 2 and 3 compatibility utilities (build for pypy)"
arch=('any')
url="http://pypi.python.org/pypi/six/"
license=('MIT')
-makedepends=('pypy' 'pypy3')
-source=(http://pypi.python.org/packages/source/s/six/six-$pkgver.tar.gz)
-md5sums=('34eed507548117b2ab523ab14b2f8b55')
+makedepends=('pypy-setuptools' 'pypy3-setuptools')
+source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
+sha512sums=('937728372edf1e0ac13bbd706723d0de35e015c30d0ae41f789c5ed2e3669bb0db70cdc6e036ec2d437a6c4aa0d5d1e727b6d09ac34cca7e4e92e5d3b4775151')
build() {
cd $srcdir
cp -r six-$pkgver six3-$pkgver
}
-check() {
- cd $srcdir/six-$pkgver
- pypy setup.py check
-
- cd $srcdir/six3-$pkgver
- pypy3 setup.py check
-}
-
package_pypy-six() {
depends=('pypy')
cd $srcdir/six-$pkgver