summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kitsinger (SwooshyCueb)2016-03-01 23:25:02 -0600
committerMarkus Kitsinger (SwooshyCueb)2016-03-01 23:25:02 -0600
commitf1d500bc39e1aaacf90244b4fbae38eae1332eba (patch)
treea82e1dd95ecd3f76428193735c28a40da2aca631
downloadaur-f1d500bc39e1aaacf90244b4fbae38eae1332eba.tar.gz
More pypy packages
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..732c158a79f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pypy-six
+ pkgdesc = Python 2 and 3 compatibility utilities (build for pypy)
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/six/
+ arch = any
+ license = MIT
+ makedepends = pypy
+ makedepends = pypy3
+ source = http://pypi.python.org/packages/source/s/six/six-1.10.0.tar.gz
+ md5sums = 34eed507548117b2ab523ab14b2f8b55
+
+pkgname = pypy-six
+ depends = pypy
+
+pkgname = pypy3-six
+ depends = pypy3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb3a1aaf5aa1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Markus Kitsinger (SwooshyCueb) <root@swooshalicio.us>
+# Contributer: Jelle van der Waa <jelle@vdwaa.nl>
+# Contributer: Allan McRae <allan@archlinux.org>
+
+pkgbase=pypy-six
+pkgname=('pypy-six' 'pypy3-six')
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="Python 2 and 3 compatibility utilities (build for pypy)"
+arch=('any')
+url="http://pypi.python.org/pypi/six/"
+license=('MIT')
+makedepends=('pypy' 'pypy3')
+source=(http://pypi.python.org/packages/source/s/six/six-$pkgver.tar.gz)
+md5sums=('34eed507548117b2ab523ab14b2f8b55')
+
+build() {
+ cd $srcdir
+ cp -r six-$pkgver six3-$pkgver
+}
+
+check() {
+ cd $srcdir/six-$pkgver
+ pypy setup.py check
+
+ cd $srcdir/six3-$pkgver
+ pypy3 setup.py check
+}
+
+package_pypy-six() {
+ depends=('pypy')
+ cd $srcdir/six-$pkgver
+ pypy setup.py install --root "${pkgdir}" --optimize=1 --prefix=/opt/pypy
+ install -Dm644 "${srcdir}/six-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_pypy3-six() {
+ depends=('pypy3')
+ cd $srcdir/six3-$pkgver
+ pypy3 setup.py install --root "${pkgdir}" --optimize=1 --prefix=/opt/pypy3
+ install -Dm644 "${srcdir}/six-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}