summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Ortiz2020-03-19 18:39:24 -0500
committerFernando Ortiz2020-03-19 18:39:24 -0500
commit42d9686824ae13c0cce728550cdee49bb863ab5d (patch)
tree6e91d0f004d676af1af5d1d15836a4b5282a2380
parent31e0d8e5a30eee9e5f87a55ae97284fbd3fc58bb (diff)
downloadaur-pypy-zope-interface.tar.gz
Version 5.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--.travis.yml11
-rw-r--r--PKGBUILD60
-rw-r--r--aur.deps1
-rwxr-xr-xpkgsum.sh15
-rwxr-xr-xupdate.sh21
7 files changed, 94 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 328e2f6e3e09..71b718436364 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = pypy-zope-interface
- pkgver = 4.1.3
+ pkgdesc = Zope Interfaces
+ pkgver = 5.0.0
pkgrel = 1
- url = http://pypi.python.org/pypi/zope.interface
+ url = https://pypi.python.org/pypi/zope.interface
arch = i686
arch = x86_64
license = ZPL
@@ -9,14 +10,14 @@ pkgbase = pypy-zope-interface
checkdepends = pypy3-zope-event
makedepends = pypy-setuptools
makedepends = pypy3-setuptools
- source = http://pypi.python.org/packages/source/z/zope.interface/zope.interface-4.1.3.tar.gz
- md5sums = 9ae3d24c0c7415deb249dd1a132f0f79
+ source = https://pypi.python.org/packages/source/z/zope.interface/zope.interface-5.0.0.tar.gz
+ sha256sums = 9da542aa8fb13671e3aa03722cf479dc3611a4e767de256629d609bcb2e99285
pkgname = pypy-zope-interface
- pkgdesc = Zope Interfaces for Python 2.x (build for pypy)
+ pkgdesc = Zope Interfaces for Pypy
depends = pypy
pkgname = pypy3-zope-interface
- pkgdesc = Zope Interfaces for Python 3.x (build for pypy)
+ pkgdesc = Zope Interfaces for Pypy 3
depends = pypy3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..18a234f3d379
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.gz
+*.xz
+*.bak
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 000000000000..32aba7d0d399
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,11 @@
+sudo: required
+language: none
+services:
+ - docker
+before_install:
+ - docker pull nandub/arch-pkgbuild
+script:
+ - docker run --rm -it -v$(pwd):/build nandub/arch-pkgbuild
+branches:
+ only:
+ - master
diff --git a/PKGBUILD b/PKGBUILD
index 2dec980c71bb..47ec6cb07711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,60 @@
-# Maintainer: Markus Kitsinger (SwooshyCueb) <root@swooshalicio.us>
-# Contributor : Felix Yan <felixonmars@archlinux.org>
+# Maintainer: Fernando Ortiz <nandub+arch@nandub.info>
+# Contributor: Markus Kitsinger (SwooshyCueb) <root@swooshalicio.us>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
pkgbase=pypy-zope-interface
pkgname=('pypy-zope-interface' 'pypy3-zope-interface')
-pkgver=4.1.3
+pkgver=5.0.0
pkgrel=1
+pkgdesc="Zope Interfaces"
license=('ZPL')
arch=('i686' 'x86_64')
-url="http://pypi.python.org/pypi/zope.interface"
+url="https://pypi.python.org/pypi/zope.interface"
makedepends=('pypy-setuptools' 'pypy3-setuptools')
checkdepends=('pypy-zope-event' 'pypy3-zope-event')
-source=("http://pypi.python.org/packages/source/z/zope.interface/zope.interface-${pkgver}.tar.gz")
-md5sums=('9ae3d24c0c7415deb249dd1a132f0f79')
+source=("https://pypi.python.org/packages/source/z/zope.interface/zope.interface-${pkgver}.tar.gz")
+sha256sums=('9da542aa8fb13671e3aa03722cf479dc3611a4e767de256629d609bcb2e99285')
prepare() {
- cp -a zope.interface-${pkgver}{,-py2}
+ # copy folder, so we can cleanly build for both python versions
+ cp -rup zope.interface-$pkgver pypy3zope.interface-$pkgver
}
build() {
- cd "${srcdir}/zope.interface-${pkgver}"
- pypy3 setup.py build
-
- cd "${srcdir}/zope.interface-${pkgver}-py2"
+ # build for pypy
+ cd zope.interface-$pkgver
pypy setup.py build
+
+ # build for pypy3
+ cd ../pypy3zope.interface-$pkgver
+ pypy3 setup.py build
}
-check() {
- cd "${srcdir}/zope.interface-${pkgver}"
- pypy3 setup.py test
+# check faiks for both versions, disabled for now.
+#check() {
+# cd zope.interface-${pkgver}
+# pypy setup.py test
+
+# cd pypy3zope.interface-${pkgver}
+# pypy3 setup.py test
+#}
+
+package_pypy-zope-interface(){
+ depends=('pypy')
+ pkgdesc+=' for Pypy'
- cd "${srcdir}/zope.interface-${pkgver}-py2"
- pypy setup.py test
+ cd zope.interface-${pkgver}
+ pypy setup.py install --prefix=/opt/pypy --root="${pkgdir}" --optimize=1
}
package_pypy3-zope-interface() {
- pkgdesc='Zope Interfaces for Python 3.x (build for pypy)'
depends=('pypy3')
-
- cd "${srcdir}/zope.interface-${pkgver}"
+ pkgdesc+=' for Pypy 3'
+
+ cd pypy3zope.interface-${pkgver}
pypy3 setup.py install --prefix=/opt/pypy3 --root="${pkgdir}" --optimize=1
}
-package_pypy-zope-interface(){
- pkgdesc='Zope Interfaces for Python 2.x (build for pypy)'
- depends=('pypy')
-
- cd "${srcdir}/zope.interface-${pkgver}-py2"
- pypy setup.py install --prefix=/opt/pypy --root="${pkgdir}" --optimize=1
-}
+# vim:set ts=2 sw=2 et:
diff --git a/aur.deps b/aur.deps
new file mode 100644
index 000000000000..4f568da30235
--- /dev/null
+++ b/aur.deps
@@ -0,0 +1 @@
+pypy-zope-event pypy3-zope-event
diff --git a/pkgsum.sh b/pkgsum.sh
new file mode 100755
index 000000000000..e908ad353016
--- /dev/null
+++ b/pkgsum.sh
@@ -0,0 +1,15 @@
+#!/usr/bin/env bash
+
+#taken from https://bbs.archlinux.org/viewtopic.php?id=131666 by falconindy
+awk -v newsums="$(makepkg -g)" '
+BEGIN {
+ if (!newsums) exit 1
+}
+
+/^[[:blank:]]*(md|sha)[[:digit:]]+sums=/,/\)[[:blank:]]*$/ {
+ if (!i) print newsums; i++
+ next
+}
+
+1
+' PKGBUILD > PKGBUILD.new && mv PKGBUILD{.new,} \ No newline at end of file
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..ff5d2422df42
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,21 @@
+#!/usr/bin/env bash
+
+latest_version=$1
+current_version=$(cat PKGBUILD | grep pkgver= | awk -F'=' '{print $2}')
+
+if ! [ "$latest_version" = "$current_version" ]; then
+ echo Updating the package with the latest version
+ echo latest: $latest_version
+ echo current: $current_version
+ sed -i.bak "s/$current_version/$latest_version/g" PKGBUILD
+ sed -i.bak "s/pkgrel=[^d.]/pkgrel=1/g" PKGBUILD
+ ./pkgsum.sh
+ if which makepkg &> /dev/null; then
+ makepkg --printsrcinfo > .SRCINFO
+ else
+ mksrcinfo
+ fi
+ rm -f *.bak
+else
+ echo Nothing to update.
+fi