summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-09-19 09:35:45 -0500
committerCarlos Aznarán2024-09-19 09:35:45 -0500
commit7f0a44a51744b08d3e493e01e84961b75de7f723 (patch)
treee278aa87493357288eaa45d09dc3361c2ed54a5e
parent5be24609771142f8c9ee217a02f28c48e3857d66 (diff)
downloadaur-7f0a44a51744b08d3e493e01e84961b75de7f723.tar.gz
Bump version to 2.13.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ded022c762b0..dc2a73af900b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pypy3-pybind11
pkgdesc = A lightweight header-only library that exposes C++ types in Python and vice versa
- pkgver = 2.13.5
+ pkgver = 2.13.6
pkgrel = 1
url = https://pybind11.readthedocs.org
arch = any
@@ -11,7 +11,7 @@ pkgbase = pypy3-pybind11
makedepends = pypy3-setuptools
depends = pypy3
optdepends = pypy3-setuptools: for python bindings
- source = https://github.com/pybind/pybind11/archive/v2.13.5/pypy3-pybind11-2.13.5.tar.gz
- sha512sums = bf9ebfbd8e694fbb421d8bdb5362a207a3782685d48988e77aed98363b2fa302e7384b570b02b117d45d5509b1633b096d4fc1ef16f65e6cc8c888b863c1e2cb
+ source = https://github.com/pybind/pybind11/archive/v2.13.6/pypy3-pybind11-2.13.6.tar.gz
+ sha512sums = 497c25b33b09a9c42f67131ab82e35d689e8ce089dd7639be997305ff9a6d502447b79c824508c455d559e61f0186335b54dd2771d903a7c1621833930622d1a
pkgname = pypy3-pybind11
diff --git a/PKGBUILD b/PKGBUILD
index ed1e2ef06233..50f45628315e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Michel Zou <xantares09@hotmail.com>
_base=pybind11
pkgname=pypy3-${_base}
-pkgver=2.13.5
+pkgver=2.13.6
pkgrel=1
pkgdesc="A lightweight header-only library that exposes C++ types in Python and vice versa"
arch=(any)
@@ -12,7 +12,7 @@ depends=(pypy3)
makedepends=(cmake boost eigen pypy3-setuptools)
optdepends=('pypy3-setuptools: for python bindings')
source=(https://github.com/${_base::6}/${_base}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
-sha512sums=('bf9ebfbd8e694fbb421d8bdb5362a207a3782685d48988e77aed98363b2fa302e7384b570b02b117d45d5509b1633b096d4fc1ef16f65e6cc8c888b863c1e2cb')
+sha512sums=('497c25b33b09a9c42f67131ab82e35d689e8ce089dd7639be997305ff9a6d502447b79c824508c455d559e61f0186335b54dd2771d903a7c1621833930622d1a')
build() {
cd ${_base}-${pkgver}
@@ -21,6 +21,6 @@ build() {
package() {
cd ${_base}-${pkgver}
- pypy3 setup.py install --prefix=/opt/pypy3 --root="$pkgdir" --skip-build --optimize='1'
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" pypy3 setup.py install --prefix=/opt/pypy3 --root="$pkgdir" --skip-build --optimize='1'
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}