summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:09:40 +0200
committerM0Rf302015-06-17 16:09:40 +0200
commitfc463d56609362be9d55790c023c47533e0879a7 (patch)
tree219a0e93d485db0999c0c6a026e2b41f7d2b9c7a
downloadaur-fc463d56609362be9d55790c023c47533e0879a7.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--pyqt4topyqt5.sh3
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f330751ef55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pyqt4topyqt5
+ pkgdesc = A tool to help to convert an application PyQt4 to PyQt5
+ pkgver = 12112013
+ pkgrel = 2
+ url = http://oqapy.eu
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ source = http://oqapy.eu/releases/pyqt4topyqt5.tar.gz
+ source = pyqt4topyqt5.sh
+ md5sums = dd76a5a290bc3244fd4187c4075b9064
+ md5sums = 1828862eb80db72059b1375ca3060286
+
+pkgname = pyqt4topyqt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55f399819ce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: M0Rf30
+
+pkgname=pyqt4topyqt5
+pkgver=12112013
+pkgrel=2
+pkgdesc="A tool to help to convert an application PyQt4 to PyQt5"
+arch=('i686' 'x86_64')
+url="http://oqapy.eu"
+license=('LGPL')
+source=("http://oqapy.eu/releases/$pkgname.tar.gz"
+ 'pyqt4topyqt5.sh')
+
+package() {
+ cd ${srcdir}/$pkgname*
+
+ install -m755 -d ${pkgdir}/usr/lib/python3.3/
+ cp *.py ${pkgdir}/usr/lib/python3.3/
+ install -D -m644 ${srcdir}/pyqt4topyqt5.sh ${pkgdir}/usr/bin/pyqt4topyqt5
+ chmod +x ${pkgdir}/usr/bin/pyqt4topyqt5
+}
+
+md5sums=('dd76a5a290bc3244fd4187c4075b9064'
+ '1828862eb80db72059b1375ca3060286')
diff --git a/pyqt4topyqt5.sh b/pyqt4topyqt5.sh
new file mode 100644
index 000000000000..735467bf5dc6
--- /dev/null
+++ b/pyqt4topyqt5.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/lib/python3.3
+python3 pyqt4topyqt5.py "$@"