summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:05 +0200
committerSébastien Leduc2015-06-13 10:51:05 +0200
commitb91527815dfeb3c1f5456164ea804a1353c714eb (patch)
treec2afeb107c3df07118ff0eb931079d79e9f336fe
downloadaur-b91527815dfeb3c1f5456164ea804a1353c714eb.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe5873129231
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pyrepl
+ pkgdesc = A Python library for building flexible command line interfaces
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pyrepl
+ arch = any
+ license = MIT
+ depends = python2
+ source = http://pypi.python.org/packages/source/p/pyrepl/pyrepl-0.8.4.tar.gz
+ md5sums = 9f02a9cc56162e2df647283d9180d7da
+
+pkgname = pyrepl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..353c4599fc43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: S.Leduc <sebastien@sleduc.fr>
+pkgname=pyrepl
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="A Python library for building flexible command line interfaces"
+url="http://pypi.python.org/pypi/pyrepl"
+arch=("any")
+license=('MIT')
+depends=('python2')
+source=("http://pypi.python.org/packages/source/p/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('9f02a9cc56162e2df647283d9180d7da')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: