summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdn062018-10-28 11:29:33 +0100
committerjdn062018-10-28 11:29:33 +0100
commit9137704998aaae9d9a435869e01370b614df29be (patch)
treefc65f4cfefc27160e434a8b37941a21ae19302b5
parent15013c4f10b986edfcc6202c7358dd1670076e86 (diff)
downloadaur-9137704998aaae9d9a435869e01370b614df29be.tar.gz
Update to 18.9.2 - pyromaths-qt is not included anymore
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52a3d9b8a597..478d7faab1fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
-# Generated by mksrcinfo v8
-# Fri Apr 7 16:30:25 UTC 2017
pkgbase = pyromaths
- pkgdesc = French program to create mathematical exercises and models
- pkgver = 15.10
- pkgrel = 3
+ pkgdesc = French program to create mathematical exercises and models, cli version
+ pkgver = 18.9.2
+ pkgrel = 1
arch = any
license = GPL3
- makedepends = python2-setuptools
- depends = python2-pyqt4
- depends = python2-lxml
+ makedepends = python-setuptools
+ depends = python-lxml
depends = texlive-pstricks
depends = texlive-latexextra
depends = texlive-fontsextra
depends = texlive-pictures
- source = http://www.pyromaths.org/telecharger/pyromaths-15.10-sources.tar.bz2
- sha256sums = 3e54004dfe7159b0dcf8aa1e7a258abb54383e0d95fa6377489d65c51cfa1482
+ source = https://files.pythonhosted.org/packages/cf/85/30902fa429bf491eeddc877ae7d26377e402445b89828fe319a552a96564/pyromaths-18.9.2.tar.gz
+ sha256sums = 21c572c3eb6b940b9121a76f8c4f60ed3258b10ec5eee490c2d274aa529957f3
pkgname = pyromaths
diff --git a/PKGBUILD b/PKGBUILD
index 67d458476095..6cb79c780b86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: jdn06 <jdn06.jdn06@outlook.fr>
pkgname=pyromaths
-pkgver=15.10
-pkgrel=3
-pkgdesc="French program to create mathematical exercises and models"
+pkgver=18.9.2
+pkgrel=1
+pkgdesc="French program to create mathematical exercises and models, cli version"
arch=(any)
license=('GPL3')
-depends=('python2-pyqt4' 'python2-lxml' 'texlive-pstricks' 'texlive-latexextra' 'texlive-fontsextra' 'texlive-pictures')
-makedepends=('python2-setuptools')
+depends=('python-lxml' 'texlive-pstricks' 'texlive-latexextra' 'texlive-fontsextra' 'texlive-pictures')
+makedepends=('python-setuptools')
optdepends=()
-source=(http://www.pyromaths.org/telecharger/$pkgname-$pkgver-sources.tar.bz2)
-sha256sums=('3e54004dfe7159b0dcf8aa1e7a258abb54383e0d95fa6377489d65c51cfa1482')
+source=(https://files.pythonhosted.org/packages/cf/85/30902fa429bf491eeddc877ae7d26377e402445b89828fe319a552a96564/$pkgname-$pkgver.tar.gz)
+sha256sums=('21c572c3eb6b940b9121a76f8c4f60ed3258b10ec5eee490c2d274aa529957f3')
package() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/"
}