summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorY2017-12-17 15:39:53 +0100
committerY2018-02-11 15:58:52 +0100
commit85952729c1918dbf17fbfd12f3053b53766fbaf1 (patch)
treed2de6e9643193cd10e700a9cb2246395ce30210b
downloadaur-85952729c1918dbf17fbfd12f3053b53766fbaf1.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05e239c587a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pyruse
+ pkgdesc = Route systemd-journal logs to filters and actions (ban, report, etc.)
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://yalis.fr/git/yves/pyruse
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python>=3.1
+ depends = python-systemd
+ optdepends = nftables: for the action_nftBan module
+ optdepends = smtp-forwarder: for the action_email and action_dailyReport modules
+ source = git+https://yalis.fr/git/yves/pyruse.git#tag=1.0
+ sha1sums = SKIP
+
+pkgname = pyruse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63cde945c70f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Yves G. <theYinYeti@yalis.fr>
+
+pkgname=pyruse
+pkgver=1.0
+pkgrel=1
+pkgdesc="Route systemd-journal logs to filters and actions (ban, report, etc.)"
+arch=('any')
+url="https://yalis.fr/git/yves/pyruse"
+license=('GPL3')
+depends=('python>=3.1' 'python-systemd')
+makedepends=('git' 'python-setuptools')
+source=("git+https://yalis.fr/git/yves/pyruse.git#tag=${pkgver}")
+sha1sums=('SKIP')
+optdepends=(
+ 'nftables: for the action_nftBan module'
+ 'smtp-forwarder: for the action_email and action_dailyReport modules'
+)
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p "${pkgdir}/etc/${pkgname}/"pyruse/{actions,filters}
+ mkdir -p "${pkgdir}/var/lib/${pkgname}"
+
+ mkdir -p "${pkgdir}/etc/systemd/system/pyruse-boot@action_nftBan.service.d"
+ cp extra/systemd/action_nftBan.conf "${pkgdir}/etc/systemd/system/pyruse-boot@action_nftBan.service.d/"
+
+ mkdir -p "${pkgdir}/usr/"
+ cp -r extra/bin "${pkgdir}/usr/"
+ chmod 755 "${pkgdir}/usr/"*
+
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ cp extra/systemd/*.service "${pkgdir}/usr/lib/systemd/system/"
+
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}/extra"
+ cp -r README.md doc "${pkgdir}/usr/share/doc/${pkgname}/"
+ cp -r extra/examples "${pkgdir}/usr/share/doc/${pkgname}/extra/"
+
+ python extra/setup/setup.py install --root="${pkgdir}/" --optimize=1
+}