summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Salmanovich2022-01-15 13:05:49 +0200
committerDenis Salmanovich2022-01-15 13:05:49 +0200
commite2b4416344ffa02fc57e0b2be6557b826df9be5c (patch)
tree4f339db5974c8373146231e7b01886137e7cd196
downloadaur-e2b4416344ffa02fc57e0b2be6557b826df9be5c.tar.gz
init commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--pyshamus.desktop9
-rw-r--r--pyshamus.pngbin0 -> 1227 bytes
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33f2c8b33cb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pyshamus
+ pkgdesc = Clone of old DOS game SHAMUS
+ pkgver = 0.6
+ pkgrel = 5
+ url = https://github.com/denix666/pyshamus
+ arch = any
+ license = GPLv3
+ makedepends = python-setuptools
+ source = http://games.os.vc/pygames/pyshamus/pyshamus-0.6-5.tar.gz
+ source = pyshamus.png
+ source = pyshamus.desktop
+ sha256sums = 2d1fbb082c5fcd8e6a93cfe1741fc8a48f267f62e24fe90fa76abc6888918eaa
+ sha256sums = 57d5647b0d9d4e691a9abbec69e0794f227b181dc5b20fcef4b2299dfc52f41b
+ sha256sums = 561b7cf458e76cb6e581912ea5ef087e6adc4f45d90364a8c917e32c065bcd32
+
+pkgname = pyshamus
+ depends = python
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc9b56eb08fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=pyshamus
+pkgver=0.6
+pkgrel=5
+pkgdesc="Clone of old DOS game SHAMUS"
+arch=("any")
+url="https://github.com/denix666/pyshamus"
+license=("GPLv3")
+makedepends=('python-setuptools')
+
+source=("http://games.os.vc/pygames/pyshamus/pyshamus-${pkgver}-${pkgrel}.tar.gz"
+ "pyshamus.png"
+ "pyshamus.desktop"
+)
+
+package () {
+ depends+=('python')
+
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}"
+
+ cd "${srcdir}"
+ install -D -m644 pyshamus.png ${pkgdir}/usr/share/pixmaps/pyshamus.png
+ install -D -m644 pyshamus.desktop ${pkgdir}/usr/share/applications/pyshamus.desktop
+}
+sha256sums=('2d1fbb082c5fcd8e6a93cfe1741fc8a48f267f62e24fe90fa76abc6888918eaa'
+ '57d5647b0d9d4e691a9abbec69e0794f227b181dc5b20fcef4b2299dfc52f41b'
+ '561b7cf458e76cb6e581912ea5ef087e6adc4f45d90364a8c917e32c065bcd32')
diff --git a/pyshamus.desktop b/pyshamus.desktop
new file mode 100644
index 000000000000..5e5b4a0d86ff
--- /dev/null
+++ b/pyshamus.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=PyShamus
+Comment=Clone of old DOS game SHAMUS
+Exec=/usr/bin/pyshamus
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/pyshamus.png
+Encoding=UTF-8
+Categories=GNOME;GTK;Game;
diff --git a/pyshamus.png b/pyshamus.png
new file mode 100644
index 000000000000..47a7a1026fa7
--- /dev/null
+++ b/pyshamus.png
Binary files differ