summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-05-14 17:40:30 +0000
committerAntonio Rojas2022-05-14 17:40:30 +0000
commitd213b6131bd80abb0b972dd24fbe59ee382bc298 (patch)
tree3f43884e18d3752eac4d38ec6bebc5dcd083484e
parent715243ea59817c079d7935f981b701baffff8ede (diff)
downloadaur-d213b6131bd80abb0b972dd24fbe59ee382bc298.tar.gz
Update to 5.15.4
-rw-r--r--PKGBUILD14
-rw-r--r--python310.patch12
2 files changed, 4 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59721238a922..81bacaab1293 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgbase=pyside2
pkgname=(shiboken2 python-shiboken2 pyside2 pyside2-tools)
-_qtver=5.15.3
+_qtver=5.15.4
_clangver=13.0.1
pkgver=${_qtver/-/}
-pkgrel=3
+pkgrel=1
arch=(x86_64)
url='https://www.qt.io'
license=(LGPL)
@@ -30,14 +30,8 @@ optdepends=('qt5-svg: QtSvg bindings'
'qt5-serialport: QtSerialPort bindings'
'qt5-quickcontrols2: QtQuickControls2 bindings')
_pkgfqn=pyside-setup-opensource-src-$_qtver
-source=(https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz
- python310.patch)
-sha256sums=('7ff5f1cc4291fffb6d5a3098b3090abe4d415da2adec740b4e901893d95d7137'
- 'dcda195170a2ada52d7914be8535926e9deea7bdcd006a4ea37b1b82dbe5cae4')
-
-prepare() {
- patch -d $_pkgfqn -p1 -i ../python310.patch # Fix build with Python 3.10
-}
+source=(https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz)
+sha256sums=('3c68ed0def4111ef5d0641370306338d277ae8983a77eaf22f223ddd3a14450b')
build() {
cmake -B build -S $_pkgfqn \
diff --git a/python310.patch b/python310.patch
deleted file mode 100644
index e6af59c84818..000000000000
--- a/python310.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -upr pyside-setup-opensource-src-5.15.2.orig/sources/shiboken2/libshiboken/pep384impl.cpp pyside-setup-opensource-src-5.15.2/sources/shiboken2/libshiboken/pep384impl.cpp
---- pyside-setup-opensource-src-5.15.2.orig/sources/shiboken2/libshiboken/pep384impl.cpp 2020-11-11 14:51:30.000000000 +0200
-+++ pyside-setup-opensource-src-5.15.2/sources/shiboken2/libshiboken/pep384impl.cpp 2021-12-01 15:17:21.444888977 +0200
-@@ -751,7 +751,7 @@ _Pep_PrivateMangle(PyObject *self, PyObj
- #endif // IS_PY2
- Shiboken::AutoDecRef privateobj(PyObject_GetAttr(
- reinterpret_cast<PyObject *>(Py_TYPE(self)), Shiboken::PyMagicName::name()));
--#ifndef Py_LIMITED_API
-+#if 0
- return _Py_Mangle(privateobj, name);
- #else
- // PYSIDE-1436: _Py_Mangle is no longer exposed; implement it always.