summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2022-06-25 15:31:42 -0400
committerCebtenzzre2022-06-25 15:53:41 -0400
commit74c6576c6dbf7b78584cb7a9878831e5435c1482 (patch)
tree00fd767715c0c4447479635503e227e49f9d806c
parent006cdc74e20e7e4431792848aab25544e9555f85 (diff)
downloadaur-74c6576c6dbf7b78584cb7a9878831e5435c1482.tar.gz
Fix build
Build from the Qt 5.15 branch instead of the Qt6 development branch, and add some missing makedepends.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f27ad576704..ff9969224b7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyside2-git
pkgdesc = Enables the use of Qt5 APIs in Python applications (git version)
- pkgver = r6554.6eb583d7
+ pkgver = r7237.d526f801c
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -21,7 +21,10 @@ pkgbase = pyside2-git
makedepends = qt5-script
makedepends = qt5-scxml
makedepends = qt5-x11extras
+ makedepends = qt5-quickcontrols2
+ makedepends = qt5-serialport
makedepends = qt5-remoteobjects
+ makedepends = qt5-xmlpatterns
depends = python-shiboken2
depends = qt5-declarative
optdepends = qt5-svg: QtSvg bindings
@@ -37,12 +40,13 @@ pkgbase = pyside2-git
optdepends = qt5-charts: QtCharts bindings
optdepends = qt5-tools: QtHelp bindings
optdepends = qt5-remoteobjects: QtRemoteObjects bindings
+ optdepends = qt5-serialport: QtSerialPort bindings
+ optdepends = qt5-quickcontrols2: QtQuickControls2 bindings
provides = python-pyside2
provides = pyside2
conflicts = python-pyside2
conflicts = pyside2
- source = pyside2-git::git+https://code.qt.io/pyside/pyside-setup.git
+ source = pyside2-git::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.15
sha256sums = SKIP
pkgname = pyside2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index af56841e0d41..d83c3834b546 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Jan-Erik Meyer-Luetgens <nyan at meyer-luetgens dot de>
pkgname=pyside2-git
-pkgver=r6554.6eb583d7
+pkgver=r7237.d526f801c
pkgrel=1
arch=(x86_64)
url='https://www.qt.io'
@@ -17,7 +17,8 @@ pkgdesc='Enables the use of Qt5 APIs in Python applications (git version)'
depends=(python-shiboken2 qt5-declarative)
makedepends=(shiboken2 cmake git
qt5-multimedia qt5-tools qt5-sensors qt5-charts qt5-webengine qt5-datavis3d
- qt5-websockets qt5-speech qt5-3d qt5-svg qt5-script qt5-scxml qt5-x11extras qt5-remoteobjects)
+ qt5-websockets qt5-speech qt5-3d qt5-svg qt5-script qt5-scxml qt5-x11extras
+ qt5-quickcontrols2 qt5-serialport qt5-remoteobjects qt5-xmlpatterns)
optdepends=('qt5-svg: QtSvg bindings'
'qt5-script: QtScript bindings'
'qt5-speech: QtTextToSpeech bindings'
@@ -30,10 +31,12 @@ optdepends=('qt5-svg: QtSvg bindings'
'qt5-x11extras: QtX11Extras bindings'
'qt5-charts: QtCharts bindings'
'qt5-tools: QtHelp bindings'
- 'qt5-remoteobjects: QtRemoteObjects bindings')
+ 'qt5-remoteobjects: QtRemoteObjects bindings'
+ 'qt5-serialport: QtSerialPort bindings'
+ 'qt5-quickcontrols2: QtQuickControls2 bindings')
conflicts=(python-pyside2 pyside2)
provides=(python-pyside2 pyside2)
-source=("$pkgname::git+https://code.qt.io/pyside/pyside-setup.git")
+source=("$pkgname::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.15")
sha256sums=('SKIP')
pkgver() {