summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-11-02 20:55:48 +0100
committerMichel Zou2017-11-02 20:55:48 +0100
commit7603d0c136f5177b4d31028a86285b8f9cb2d624 (patch)
tree5c88d37f0ee9ba420625b07f597d83cfb20f45ef
parenta521de8e0e0cab928ca011811206bd99d073b473 (diff)
downloadaur-7603d0c136f5177b4d31028a86285b8f9cb2d624.tar.gz
try shiboken
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 227b20cccbb1..df70529474cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Nov 1 17:18:44 UTC 2017
+# Thu Nov 2 19:55:47 UTC 2017
pkgbase = pyside2-git
pkgver = 2.0.0.r5308.25f899e2
pkgrel = 1
@@ -9,8 +9,6 @@ pkgbase = pyside2-git
license = LGPL
makedepends = python
makedepends = python2
- makedepends = python-shiboken2-git
- makedepends = python2-shiboken2-git
makedepends = cmake
makedepends = phonon-qt5
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 528080ccf331..ae37aecf97fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,8 @@ pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
url="http://qt-project.org/wiki/PySide"
-makedepends=('python' 'python2' "python"{,2}"-shiboken2-git" 'cmake'
+# "python"{,2}"-shiboken2-git"
+makedepends=('python' 'python2' 'cmake'
'phonon-qt5' 'git' 'python2-sphinx' 'graphviz' 'qt5-base'
'qt5-xmlpatterns' 'qt5-tools' 'qt5-multimedia' 'qt5-declarative'
'qt5-script' 'qt5-speech' 'qt5-svg' 'qt5-webchannel'
@@ -37,14 +38,24 @@ prepare() {
}
build(){
+ # Build shiboken here waiting for AUR package shiboken2-git to be orphaned
+ cd "$srcdir"/$pkgbase/sources/shiboken2
+ mkdir -p build-py2 && cd build-py2
+ cmake -DCMAKE_INSTALL_PREFIX=$PWD/install \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_PYTHON_VERSION=2 \
+ -DBUILD_TESTS=OFF ..
+ make install
+
# Build for python2.
cd "$srcdir"/$pkgbase/sources/pyside2
mkdir -p build-py2 && cd build-py2
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DPYTHON_EXTENSION_SUFFIX=-python2.7 \
- -DUSE_PYTHON_VERSION=2 \
- -DBUILD_TESTS=OFF
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_PYTHON_VERSION=2 \
+ -DBUILD_TESTS=OFF \
+ -DShiboken2_DIR="$srcdir"/$pkgbase/sources/shiboken2/build-py2/install/lib/cmake/Shiboken2-2.0.0 \
+ ..
make
# Build for python3.