summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoradvaithm2020-12-29 13:11:36 +0530
committeradvaithm2020-12-29 13:11:36 +0530
commit2e1c1b58c466e1fc44a4e5b7ed2cf170c7040cca (patch)
tree637d21f450537dc0482ec76a0e0074943fe3e040
parentbcfda0f9c0be5626d25408234d197882db6a180f (diff)
downloadaur-2e1c1b58c466e1fc44a4e5b7ed2cf170c7040cca.tar.gz
reworked to avoid confilcts
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2f534177567..bf027d076b15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = pyside6-tools
pkgdesc = Tools for PySide6
pkgver = 6.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io
arch = x86_64
license = LGPL
makedepends = cmake
makedepends = shiboken6
depends = pyside6
+ conflicts = pyside2-tools
source = https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-6.0.0-src/pyside-setup-opensource-src-6.0.0.tar.xz
sha256sums = f47a4598118510feecc96b9d4b01063d206ac9a1240af3545163d2891db27dd4
diff --git a/PKGBUILD b/PKGBUILD
index e4496d0b0035..b01f66372d45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=pyside6-tools
_qtver=6.0.0
pkgver=${_qtver/-/}
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url='https://www.qt.io'
license=(LGPL)
pkgdesc='Tools for PySide6'
depends=(pyside6)
+conflicts=(pyside2-tools)
makedepends=(cmake shiboken6)
_pkgfqn=pyside-setup-opensource-src-$_qtver
source=("https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-$pkgver-src/${_pkgfqn}.tar.xz")
@@ -23,6 +24,6 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
-
- rm "$pkgdir"/usr/bin/{rcc,uic} # provided by qt6-base
+ rm "$pkgdir"/usr/bin/{rcc,designer}
+ mv "$pkgdir"/usr/bin/uic "$pkgdir"/usr/bin/pyside6-uic
}