summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLizen_52022-05-29 02:18:01 +0200
committerLizen_52022-05-29 02:18:01 +0200
commit5f9ebec55b08f5a6805b8eac2920cd6529b7f72a (patch)
tree00a1712b850bdf417d4b1be17f8e59c56bdeb535
parent005d1ff7789323533245b26da35ad57173655311 (diff)
downloadaur-5f9ebec55b08f5a6805b8eac2920cd6529b7f72a.tar.gz
Package adjustement
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34b3aec47634..7e412c669291 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = pyside6-tools
pkgdesc = Tools for PySide6
pkgver = 6.3.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.qt.io
arch = x86_64
license = LGPL
makedepends = cmake
makedepends = shiboken6
+ makedepends = qt6-tools
depends = pyside6
- depends = qt6-tools
conflicts = pyside2-tools
source = https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-6.3.0-src/pyside-setup-opensource-src-6.3.0.tar.xz
sha256sums = 9d808d617c8daa2fe074f9a481478dc923a9799b5c89f6c5af38ece111ed57e2
diff --git a/PKGBUILD b/PKGBUILD
index 2755776ece8e..69fcb3587e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Advaith Madhukar <advaith.madhukar at gmail dot com>
+# Maintainer: Lizen_5 <rs.supermarios at gmail dot com>
+# Contributor: Advaith Madhukar <advaith.madhukar at gmail dot com>
pkgname=pyside6-tools
_qtver=6.3.0
pkgver=${_qtver/-/}
-pkgrel=3
+pkgrel=4
arch=(x86_64)
url='https://www.qt.io'
license=(LGPL)
pkgdesc='Tools for PySide6'
-depends=(pyside6 qt6-tools)
+depends=(pyside6)
conflicts=(pyside2-tools)
-makedepends=(cmake shiboken6)
+makedepends=(cmake shiboken6 qt6-tools)
_pkgfqn=pyside-setup-opensource-src-$_qtver
source=("https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-$pkgver-src/${_pkgfqn}.tar.xz")
sha256sums=('9d808d617c8daa2fe074f9a481478dc923a9799b5c89f6c5af38ece111ed57e2')
@@ -24,6 +25,8 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
- rm "$pkgdir"/usr/bin/{rcc,designer,assistant,linguist,lrelease,lupdate,qmllint,qmltyperegistrar}
+ rm "$pkgdir"/usr/bin/{rcc,designer,assistant,linguist,qmllint,qmltyperegistrar}
mv "$pkgdir"/usr/bin/uic "$pkgdir"/usr/bin/pyside6-uic
+ mv "$pkgdir"/usr/bin/lupdate "$pkgdir"/usr/bin/pyside6-lupdate
+ mv "$pkgdir"/usr/bin/lrelease "$pkgdir"/usr/bin/pyside6-lrelease
}