summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoradvaithm2020-12-29 11:57:17 +0530
committeradvaithm2020-12-29 11:57:17 +0530
commitacd6dd7cacc0ef74526ebc65ab4e93125b33bb20 (patch)
tree8752fa46d4989d8ec5a96e0a8efa39b78c6d1fbd
downloadaur-acd6dd7cacc0ef74526ebc65ab4e93125b33bb20.tar.gz
created pyside6-tools
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f9f6634bb04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pyside2-tools
+ pkgdesc = Tools for PySide6
+ pkgver = 6.0.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = shiboken6
+ depends = pyside6
+ source = https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-6.0.0-src/pyside-setup-opensource-src-6.0.0.tar.xz
+ sha256sums = f47a4598118510feecc96b9d4b01063d206ac9a1240af3545163d2891db27dd4
+
+pkgname = pyside2-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7f0d1a31b05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Advaith Madhukar <advaith.madhukar at gmail dot com>
+
+pkgname=pyside2-tools
+_qtver=6.0.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(x86_64)
+url='https://www.qt.io'
+license=(LGPL)
+pkgdesc='Tools for PySide6'
+depends=(pyside6)
+makedepends=(cmake shiboken6)
+_pkgfqn=pyside-setup-opensource-src-$_qtver
+source=("https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-$pkgver-src/${_pkgfqn}.tar.xz")
+sha256sums=('f47a4598118510feecc96b9d4b01063d206ac9a1240af3545163d2891db27dd4')
+
+build() {
+ cmake -B build -S ${_pkgfqn}/sources/pyside-tools/ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+
+ rm "$pkgdir"/usr/bin/{rcc,uic} # provided by qt6-base
+}