summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorranger2015-06-24 19:49:45 +0000
committerranger2015-06-24 19:49:45 +0000
commit72225edffc05177d2d07885cb5bcd54f938ff586 (patch)
tree8e057e7490eeb7b5b26c28b78cfcbc63974dbd09
downloadaur-pysmssend.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD36
-rwxr-xr-xpysmssend-desktop.diff14
-rw-r--r--pysmssend.changelog220
4 files changed, 288 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ac7a51d2186
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pysmssend
+ pkgdesc = Application for sending SMS over the Internet
+ pkgver = 1.48
+ pkgrel = 4
+ url = http://pysmssend.silverarrow.org/
+ changelog = pysmssend.changelog
+ arch = any
+ license = GPL3
+ makedepends = patch
+ depends = python2-pyqt4
+ depends = python2-mechanize
+ source = http://pysmssend.silverarrow.org/files/pysmssend-1.48.tar.gz
+ source = pysmssend-desktop.diff
+ md5sums = 6f646a4267151bfae623895d9c12cdd2
+ md5sums = 605cff59b56682b9589e4af50bea0fdd
+
+pkgname = pysmssend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c4f97bc59629
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: ranger <rangergr@archlinux.gr>
+pkgname=pysmssend
+pkgver=1.48
+pkgrel=4
+pkgdesc="Application for sending SMS over the Internet"
+arch=('any')
+url="http://pysmssend.silverarrow.org/"
+license=('GPL3')
+depends=('python2-pyqt4' 'python2-mechanize')
+makedepends=('patch')
+changelog=$pkgname.changelog
+source=("http://pysmssend.silverarrow.org/files/${pkgname}-${pkgver}.tar.gz" \
+ $pkgname-desktop.diff)
+
+md5sums=('6f646a4267151bfae623895d9c12cdd2'
+ '605cff59b56682b9589e4af50bea0fdd')
+
+package(){
+ cd "${srcdir}/"
+ patch -Np0 -i "${srcdir}/$pkgname-desktop.diff"
+
+ # python2 fix
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' pysmssend
+
+ python2 setup.py install --root ${pkgdir}
+
+ install -d ${pkgdir}/usr/share/$pkgname
+ install -D -m755 "$pkgname" "${pkgdir}/usr/bin/$pkgname"
+ install -D -m755 "pysmssendcmd" "${pkgdir}/usr/bin/pysmssendcmd"
+ install -D -m644 "Icons/$pkgname.png" "${pkgdir}/usr/share/pixmaps/$pkgname.png"
+ install -D -m644 "$pkgname.desktop" "${pkgdir}/usr/share/applications/$pkgname.desktop"
+
+ cp -R * ${pkgdir}/usr/share/$pkgname
+ rm -rf ${pkgdir}/usr/share/pysmssend/{build,pysmssendmod}
+ rm ${pkgdir}/usr/share/pysmssend/{setup.py,pysmssend*,*.sh}
+}
diff --git a/pysmssend-desktop.diff b/pysmssend-desktop.diff
new file mode 100755
index 000000000000..2578f0001b2a
--- /dev/null
+++ b/pysmssend-desktop.diff
@@ -0,0 +1,14 @@
+--- pysmssend.desktop.old 2008-04-03 22:33:44.000000000 +0200
++++ pysmssend.desktop 2008-09-26 14:34:51.000000000 +0200
+@@ -3,2 +3,4 @@
+ Comment=Send SMS over the Internet
++Comment[cs]=Posílej SMS po Internetu
++Comment[gr]=Εφαρμογή για την αποστολη μηνηματών μέσω του Internet
+ Exec=pysmssend
+@@ -7,5 +9,2 @@
+ Type=Application
+-Encoding=UTF-8
+-Categories=Application;Network;
+-
+-
++Categories=Network;
diff --git a/pysmssend.changelog b/pysmssend.changelog
new file mode 100644
index 000000000000..1b4f0d80eeec
--- /dev/null
+++ b/pysmssend.changelog
@@ -0,0 +1,220 @@
+ ***************************CHANGE LOG********************
+
+** 1.48
+1) Fix accounts for Forthnet and Voipbuster providers
+2) Clean up
+
+** 1.45
+
+1) Fix local variable bug ( bug #3002071 )
+2) Fix Betamax login page url
+
+** 1.44
+
+1) Code clean up
+2) Pennytel support
+3) Fix connection bugs for betamax sites
+
+** 1.42
+
+1) Code clean up
+2) Support Forthnet Greek ISP
+3) Compatible with PyQt4-4.5
+4) Drop support for Yahoo provider
+
+**1.40
+
+1) Code has been re-written for betamax sites due to compatibility issues
+2) Code clean up
+
+**1.39
+
+1) Fixed bug with addressbook initialization
+
+**1.38
+
+1) Improved control for message report
+2) Tray icon has been re-written
+3) Added voipcheap support
+4) Added -v option when running Gui. Verbose output
+5) Fix feedback when sending a message.
+6) Remember Me checkbox is now by default checked.
+7) Check for updates when the program starts.
+8) Compatibility fixed for both kde3+kde4 kaddressbook. Needs more testing though
+
+**1.37
+
+1) Added JustVoip support
+2) Small bugfixes
+3) Updated for python2.5 support
+
+**1.36
+Major fixes in this version
+
+Since betamax change the way users login to their site I had to re-write most of the code so you should except some problems
+
+So the changes are
+
+1) Betamax accounts do not need to login anymore. You just fill all the info (username,password,number,text) and then click the Send button
+2) Because of the above change ,credits left wont be available (for now) for betamax sites
+3) Some code cleenup
+4) Fixed install script
+5) Donate tab on About menu
+
+**1.35
+
+1) Fixed myinserts module
+
+**1.34
+
+1)Wrong Credits Left Indication after message sent fixed
+2)Added WebcallDirect Support (Beta)
+3)Modular application. Application is splitted into multiple files. Now
+its much faster and can be maintained more easily
+
+**1.32
+Beta support for Yahoo SMS Service
+http://everywhere.yahoo.com/sms/sendsms
+
+
+**1.31
+
+One small fix. This fix enables .deb package to work great with ubuntu
+
+**1.30
+
+code fixes
+
+**1.29
+Ignore robots.txt file on otenet
+
+**1.28
+
+1) Improved addressbook code. Faster code. Contacts are stored in memory not in file
+2) Account manager for multiple accounts
+3) Bug fixes
+a) Fixed login check control to above Betamaxes pop up mesages
+b) Fixed credits left function
+4) Tray Icon informing you about login status and sms report
+5) Update options. Notifies you if there is update or not
+
+**1.24
+1) One main interface. Main and Addressbook are now on program
+2) Support for
+ a) Voipbusterpro
+ b) LowrateVoip
+ c) 12voip
+ d) Freevoip
+3) Messages left and Credits left now appear on Gui and on cmd tool. User wont be able to send sms if the credits are <0.05 or messages left are 0 ( for otenet )
+4) Gui for Addressbook now is loaded as module
+5) Kaddressbook code fixed. Now works fine for users who doesnt have Kaddressbook installed. The program will try to find std.vcf file . If not the Addressbook wont show anything but it wont crash like the previous version
+6) Fixed Gui interface
+
+
+
+**1.22
+
+1) New impoved main code
+2) Gui and main code now they are two different files
+3) Added verbose option on command line interface. No information is displayed when running on No-verbose mode
+4) Bux fixes
+5) Text length message check on commanline tool
+6) Fixes on temporary create and delete files
+7) Fixed installed script
+
+** 1.20
+
+1) New Addressbook code
+Details:
+a) Now there is no need of having both first and last name on addressbook and also a contact might not have a cell phone
+b) Better Gui
+c) Unicode support fixed
+
+2) Main code fixes
+3) Command line program fixes
+
+
+
+** 1.18
+
+1) Sms can now run from command line too
+2) Code modification for Gentoo Ebuilds
+3) Bug Fixes and code spelling errors
+4) Name changed to pysmssend
+5) Fixed icon transparency
+6) Pkgbuild available
+7) Ebuild availabe
+8) Addressbook marked as Beta Version
+
+
+
+**1.1
+
+I'd like to thank Ioannis for supporting,debugging and developing the program
+
+
+1) Remember me Option
+2) New Interface
+3) Fixed Code
+
+
+
+**1.09
+
+Latest version of the program
+
+Stable version
+
+1) Fixed Code
+2) Icons Added
+3) Fixed Interface
+
+
+** 1.08beta
+
+1) Supports Voipdiscount ( need feedback )
+2) Fixed spelling mistakes
+
+
+
+** 1.07
+
+ Alpha version for voipdiscount support
+
+** 1.06
+
+1) Read contacts from address book
+The program assumes you have your contacts stored on ~/.kde/share/apps/kabc/std.vcf
+
+2) Inserts the Selected Number from the addressbook on Number field
+
+** 1.05 beta
+
+1) First Attemp co-operating with kaddressbook
+
+** 1.04
+
+1) Support for OTEnet Web2SMS
+
+** 1.03
+
+1) Password now appears with *
+2) Login feedback fixed
+3) Message length can now be checked by pressing the button "Check Characters"
+4) Final Check of message length before sending the sms
+5) Smaller size
+
+
+** 1.02
+
+Second and Stable version of the Program
+
+Fixes:
+
+1) Feedback on loggin
+2) Feedback if the sms sent or not
+3) Correct the Message if it is bigger than 160 characters
+
+** 0.8
+
+First Version of the program. The program didnt send any feedback back. It was just for testing