summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiorgio Gilestro2015-09-17 16:04:03 +0100
committerGiorgio Gilestro2015-09-17 16:04:03 +0100
commit99311668f6d8e4ccdbbc07dad4d08ebd9d57f6c0 (patch)
tree0c16e09ea84e306e778f0bb281307f0134998045
downloadaur-99311668f6d8e4ccdbbc07dad4d08ebd9d57f6c0.tar.gz
Initial Import into new AUR using git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--pysolo.desktop10
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1b201579e42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pysolo
+ pkgdesc = A software for sleep analysis in Drosophila
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://www.pysolo.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = wxpython
+ depends = python2-scipy
+ depends = python2-numpy
+ depends = python2-matplotlib
+ source = http://ppa.pysolo.net/pool/main/pysolo_1.0.1.orig.tar.gz
+ source = pysolo.desktop
+ md5sums = c91c4b747aa858df527b3b2639201eb9
+ md5sums = 91592bd8ead236254da26d336ebd9ee3
+
+pkgname = pysolo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..422cfa7c40d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Giorgio Gilestro <giorgio@gilest.ro>
+
+pkgname=pysolo
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A software for sleep analysis in Drosophila"
+arch=('i686' 'x86_64')
+depends=('python2' 'wxpython' 'python2-scipy' 'python2-numpy' 'python2-matplotlib')
+url="http://www.pysolo.net"
+license=('GPL')
+
+source=(http://ppa.pysolo.net/pool/main/${pkgname}_${pkgver}.orig.tar.gz ${pkgname}.desktop)
+md5sums=('c91c4b747aa858df527b3b2639201eb9' '91592bd8ead236254da26d336ebd9ee3')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ sed -i 's/env python/env python2/' pysolo.py pysolo_anal.py pysolo_db.py
+ sed -i 's/debian=False/debian=True/' pysolo_path.py
+}
+
+package() {
+ install -d $pkgdir/usr/share/applications
+ install -d $pkgdir/opt/pysolo
+
+ cp -r * $pkgdir/opt/pysolo/
+ cp $srcdir/*.desktop $pkgdir/usr/share/applications/
+}
+
diff --git a/pysolo.desktop b/pysolo.desktop
new file mode 100644
index 000000000000..f189af5d6547
--- /dev/null
+++ b/pysolo.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Icon=/opt/pysolo/img/pysolo.png
+Name=pySolo
+Comment=A software for sleep analysis in Drosophila
+Exec=/usr/bin/pysolo
+Terminal=false
+Type=Application
+Categories=Biology;Science;Education;
+StartupNotify=false