summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-20 07:33:23 +0300
committerDimitris Kiziridis2020-07-20 07:33:23 +0300
commit96395923200961d938811e0486ca978ef5defb01 (patch)
tree7b5e837f573259f99aa127801e9bdca94fb02af7
downloadaur-96395923200961d938811e0486ca978ef5defb01.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84678ed94bed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pysorter
+ pkgdesc = A command line utility for organizing files and directories according to regex patterns
+ pkgver = 0.4.4.r3.g8b4cf72
+ pkgrel = 1
+ url = https://github.com/chriscz/pysorter
+ arch = any
+ license = MPL2
+ makedepends = python-setuptools
+ depends = python
+ conflicts = pysorter
+ source = pysorter::git+https://github.com/chriscz/pysorter
+ sha256sums = SKIP
+
+pkgname = pysorter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3594ad8ab8e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=pysorter
+pkgver=0.4.4.r3.g8b4cf72
+pkgrel=1
+pkgdesc='A command line utility for organizing files and directories according to regex patterns'
+arch=('any')
+url='https://github.com/chriscz/pysorter'
+license=('MPL2')
+conflicts=('pysorter')
+depends=('python')
+makedepends=('python-setuptools')
+source=("${pkgname%-git}::git+https://github.com/chriscz/pysorter")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname%-git}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file