summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Petitjean2015-06-08 17:04:48 +0200
committerAlexandre Petitjean2015-06-08 17:04:48 +0200
commit0e01a853fd8783bfffacf9748bda4eb96deb794d (patch)
tree5adefe3e4e72bb29bc4b1feffc06742a23eef810
downloadaur-0e01a853fd8783bfffacf9748bda4eb96deb794d.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0b2dfd3fad6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pyspotify
+ pkgdesc = A Python Spotify library
+ pkgver = 1.12
+ pkgrel = 2
+ url = http://pyspotify.mopidy.com/
+ arch = any
+ license = APACHE
+ makedepends = python2-distribute
+ depends = python2
+ depends = libspotify
+ optdepends = python-pyalsaaudio: Used by example applications.
+ provides = pyspotify
+ conflicts = pyspotify-git
+ source = https://github.com/mopidy/pyspotify/archive/v1.12.tar.gz
+ md5sums = ce47484df6011ad9a3eeb37368f30880
+
+pkgname = pyspotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ec84b57f91d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexandre Petitjean <alpetitjean at gmail dot com>
+
+pkgname=pyspotify
+pkgver=1.12
+pkgrel=2
+pkgdesc="A Python Spotify library"
+arch=('any')
+url="http://pyspotify.mopidy.com/"
+license=('APACHE')
+depends=('python2' 'libspotify')
+makedepends=('python2-distribute')
+optdepends=('python-pyalsaaudio: Used by example applications.')
+conflicts=('pyspotify-git')
+provides=('pyspotify')
+source=("https://github.com/mopidy/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('ce47484df6011ad9a3eeb37368f30880')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: