summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2017-12-18 23:21:47 +0100
committerJake2017-12-18 23:21:47 +0100
commit06a71f713f54d7378658daf547af9b08de7d2e59 (patch)
treefb34edd596173b8c847b6d08bbac7f15d0ddeb45
parentc4a3c02fbf7f4ae3702790187e78fe2a61b529cc (diff)
downloadaur-06a71f713f54d7378658daf547af9b08de7d2e59.tar.gz
Update to 1.1.1
and add desktop file
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
-rw-r--r--pyspread.desktop13
3 files changed, 43 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18510172f0bc..64341a798cd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = pyspread
pkgdesc = A cross-platform Python spreadsheet application. Python 2.7 version
- pkgver = 1.0.3
+ pkgver = 1.1.1
pkgrel = 1
url = https://manns.github.io/pyspread/
arch = any
license = GPL3
- depends = python2>=2.7.0
depends = python2-numpy>=1.1.0
depends = wxpython
depends = python2-matplotlib
- depends = cairo>=1.8.8
+ depends = python2-cairo
+ depends = python2-gnupg
optdepends = python2-gnupginterface: for opening files without approval
optdepends = python2-xlrd: open Excel files
optdepends = python2-xlwt: save Excel files
optdepends = python2-jedi: TAB autocompletion and context help in the entry line
optdepends = python2-basemap: for the weather example
+ optdepends = python2-pyenchant: for spell checking
options = !emptydirs
- source = https://pypi.python.org/packages/f9/01/a3b4be117b4ea69d0d2c96fdfff47de9a4c61ba8295ed4f4a6ca5eb60306/pyspread-1.0.3.tar.gz
- md5sums = b240c8fb57ce7354334982266fae47b5
+ source = https://github.com/manns/pyspread/archive/v1.1.1.tar.gz
+ source = pyspread.desktop
+ sha512sums = 46fc9e487876c1e903b4f25c7f29423901ce9580bb3916f60fac8358d76cfcd78b4315de191aaf41745331eac899422693e3b1fb259df79ba6d8c02f53553ff6
+ sha512sums = 9411c1c4c9c68132bdc05fc028b4a3d1dade65502a21c64bcd093f94fe7ed6e7dee3f34a2a423da263f73dd5f20c1fcbfb0734ec60e5789057296dd8d48895d2
pkgname = pyspread
diff --git a/PKGBUILD b/PKGBUILD
index 99cce61f8f92..ad9ee324eb53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,42 @@
-# Maintainer: Alexander Scharinger <e1028732 at student dot tuwien dot ac dot at>
+# Maintainer: Jake <ja.ke@posteo.de>
+# Contributor: Alexander Scharinger
# Contributor: Tristan Webb <t2webb@ucsd.edu>
# Contributor Sindwiller
pkgname=pyspread
-pkgver=1.0.3
+pkgver=1.1.1
pkgrel=1
pkgdesc="A cross-platform Python spreadsheet application. Python 2.7 version"
arch=('any')
url="https://manns.github.io/pyspread/"
license=('GPL3')
-depends=('python2>=2.7.0' 'python2-numpy>=1.1.0' 'wxpython' 'python2-matplotlib'
- 'cairo>=1.8.8')
-options=(!emptydirs)
-source=('https://pypi.python.org/packages/f9/01/a3b4be117b4ea69d0d2c96fdfff47de9a4c61ba8295ed4f4a6ca5eb60306/pyspread-1.0.3.tar.gz')
+depends=('python2-numpy>=1.1.0'
+ 'wxpython' # needs pycairo patch
+ 'python2-matplotlib'
+ 'python2-cairo'
+ 'python2-gnupg')
+optdepends=('python2-gnupginterface: for opening files without approval' # in AUR
+ 'python2-xlrd: open Excel files' # in Community
+ 'python2-xlwt: save Excel files' # in Community
+ 'python2-jedi: TAB autocompletion and context help in the entry line' # in Community
+ 'python2-basemap: for the weather example' # in Community
+ 'python2-pyenchant: for spell checking') # in Community
# The pyspread website lists another optional dependency: pyrsvg>=2.32, for
# displaying SVG files in cells. But pyrsvg is included in cairo (from the
# mandatory dependencies).
# See: https://manns.github.io/pyspread/download.html and on this site follow
# link to pyrsvg.
-optdepends=('python2-gnupginterface: for opening files without approval' # in AUR
- 'python2-xlrd: open Excel files' # in Community
- 'python2-xlwt: save Excel files' # in Community
- 'python2-jedi: TAB autocompletion and context help in the entry line' # in Community
- 'python2-basemap: for the weather example' ) # in Community
-# To update the md5sum use the following command.
-# $ makepkg -g >> PKGBUILD
-md5sums=('b240c8fb57ce7354334982266fae47b5')
+options=(!emptydirs)
+source=("https://github.com/manns/pyspread/archive/v${pkgver}.tar.gz"
+ "$pkgname.desktop")
+sha512sums=('46fc9e487876c1e903b4f25c7f29423901ce9580bb3916f60fac8358d76cfcd78b4315de191aaf41745331eac899422693e3b1fb259df79ba6d8c02f53553ff6'
+ '9411c1c4c9c68132bdc05fc028b4a3d1dade65502a21c64bcd093f94fe7ed6e7dee3f34a2a423da263f73dd5f20c1fcbfb0734ec60e5789057296dd8d48895d2')
-package() {
+package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python2 setup.py install --root=$pkgdir/ --optimize=1
mv $pkgdir/usr/lib/python2.7/site-packages/{changelog,README} \
$pkgdir/usr/lib/python2.7/site-packages/pyspread/
+ install -D "$pkgdir/usr/lib/python2.7/site-packages/pyspread/share/icons/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -D -m644 "${srcdir}/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}
-# vim:set ts=2 sw=2 et:
diff --git a/pyspread.desktop b/pyspread.desktop
new file mode 100644
index 000000000000..b34bf4d3e9da
--- /dev/null
+++ b/pyspread.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Categories=Development
+Exec=pyspread
+Comment=Python power for your tables
+Icon=pyspread
+MimeType=
+Name=pyspread
+Path=
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+