summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2020-05-10 00:43:55 +0200
committerJake2020-05-10 00:43:55 +0200
commit3979d4d7f22d349cebca5d112690f8c3c4cef6de (patch)
tree585d1395c8a57c5526d6c33d3cbc63aadd889244
parent094327715e4d73bc969cf9b97ef879fc24459003 (diff)
downloadaur-3979d4d7f22d349cebca5d112690f8c3c4cef6de.tar.gz
Update to 1.99.2
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--pyspread.desktop13
3 files changed, 24 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41f42d166350..6dbb9a4e30c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,19 @@
pkgbase = pyspread
pkgdesc = A cross-platform Python spreadsheet application. Python 2.7 version
- pkgver = 1.99.1
+ pkgver = 1.99.2
pkgrel = 1
url = https://manns.github.io/pyspread/
arch = any
license = GPL3
- depends = python2-numpy>=1.1.0
- depends = wxpython
- depends = python2-matplotlib
- depends = python2-cairo
- depends = python2-gnupg
- optdepends = python2-gnupginterface: for opening files without approval
- optdepends = python2-xlrd: open Excel files
- optdepends = python2-xlwt: save Excel files
- optdepends = python2-jedi: TAB autocompletion and context help in the entry line
- optdepends = python2-basemap: for the weather example
- optdepends = python2-pyenchant: for spell checking
+ depends = python-numpy>=1.1.0
+ depends = python-pyqt5
+ depends = qt5-svg
+ optdepends = python-matplotlib
+ optdepends = python-pyenchant
+ optdepends = python-pip
options = !emptydirs
- source = https://github.com/manns/pyspread/archive/v1.99.1.tar.gz
- source = pyspread.desktop
- sha512sums = e9be7edfede1d150fbe72edf9eab16ce39c3d3fb844345628194541d2386a33203a18d8081b02b8ee7b7821a35f0990da01225256dbdfc353f64eeae4738a534
- sha512sums = 9411c1c4c9c68132bdc05fc028b4a3d1dade65502a21c64bcd093f94fe7ed6e7dee3f34a2a423da263f73dd5f20c1fcbfb0734ec60e5789057296dd8d48895d2
+ source = https://gitlab.com/pyspread/pyspread/-/archive/v1.99.2/pyspread-v1.99.2.tar.gz
+ sha512sums = 9261cf96f19d92a5743c09854236ccec5e1b103e22b78143ddee8fce0d25f793b86e7cc3775f13c5a43cf8dd4e3f434461677b6da5311fb439067d63ce6ac968
pkgname = pyspread
diff --git a/PKGBUILD b/PKGBUILD
index 58a8d6908d10..13850f341838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,29 @@
# Contributor: Alexander Scharinger
# Contributor: Tristan Webb <t2webb@ucsd.edu>
# Contributor Sindwiller
+
pkgname=pyspread
-pkgver=1.99.1
+pkgver=1.99.2
pkgrel=1
pkgdesc="A cross-platform Python spreadsheet application. Python 2.7 version"
arch=('any')
url="https://manns.github.io/pyspread/"
license=('GPL3')
-depends=('python2-numpy>=1.1.0'
- 'wxpython' # needs pycairo patch
- 'python2-matplotlib'
- 'python2-cairo'
- 'python2-gnupg')
-optdepends=('python2-gnupginterface: for opening files without approval' # in AUR
- 'python2-xlrd: open Excel files' # in Community
- 'python2-xlwt: save Excel files' # in Community
- 'python2-jedi: TAB autocompletion and context help in the entry line' # in Community
- 'python2-basemap: for the weather example' # in Community
- 'python2-pyenchant: for spell checking') # in Community
-# The pyspread website lists another optional dependency: pyrsvg>=2.32, for
-# displaying SVG files in cells. But pyrsvg is included in cairo (from the
-# mandatory dependencies).
-# See: https://manns.github.io/pyspread/download.html and on this site follow
-# link to pyrsvg.
+depends=('python-numpy>=1.1.0'
+ 'python-pyqt5'
+ 'qt5-svg')
+optdepends=('python-matplotlib'
+ 'python-pyenchant'
+ 'python-pip')
options=(!emptydirs)
-source=("https://github.com/manns/pyspread/archive/v${pkgver}.tar.gz"
- "$pkgname.desktop")
-sha512sums=('e9be7edfede1d150fbe72edf9eab16ce39c3d3fb844345628194541d2386a33203a18d8081b02b8ee7b7821a35f0990da01225256dbdfc353f64eeae4738a534'
- '9411c1c4c9c68132bdc05fc028b4a3d1dade65502a21c64bcd093f94fe7ed6e7dee3f34a2a423da263f73dd5f20c1fcbfb0734ec60e5789057296dd8d48895d2')
+source=("https://gitlab.com/pyspread/pyspread/-/archive/v${pkgver}/pyspread-v${pkgver}.tar.gz")
+sha512sums=('9261cf96f19d92a5743c09854236ccec5e1b103e22b78143ddee8fce0d25f793b86e7cc3775f13c5a43cf8dd4e3f434461677b6da5311fb439067d63ce6ac968')
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python2 setup.py install --root=$pkgdir/ --optimize=1
- mv $pkgdir/usr/lib/python2.7/site-packages/{changelog,README} \
- $pkgdir/usr/lib/python2.7/site-packages/pyspread/
- install -D "$pkgdir/usr/lib/python2.7/site-packages/pyspread/share/icons/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
- install -D -m644 "${srcdir}/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ python setup.py install --root=$pkgdir/ --optimize=1
+
+ install -D "${pkgname}/share/icons/$pkgname.svg" "$pkgdir/usr/share/pixmaps/$pkgname.svg"
+ install -D -m644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
}
diff --git a/pyspread.desktop b/pyspread.desktop
deleted file mode 100644
index b34bf4d3e9da..000000000000
--- a/pyspread.desktop
+++ /dev/null
@@ -1,13 +0,0 @@
-[Desktop Entry]
-Categories=Development
-Exec=pyspread
-Comment=Python power for your tables
-Icon=pyspread
-MimeType=
-Name=pyspread
-Path=
-StartupNotify=true
-Terminal=false
-TerminalOptions=
-Type=Application
-