summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Scharinger2015-07-09 19:22:57 +0200
committerAlexander Scharinger2015-07-09 19:22:57 +0200
commitab8d89792d5fd6024ffedb0314191662a94a49f4 (patch)
treefcc2ef6be9c94095270eacc71bccddd3d13014a2
downloadaur-ab8d89792d5fd6024ffedb0314191662a94a49f4.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23c01c216b47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pyspread
+ pkgdesc = A cross-platform Python spreadsheet application. Python 2.7 version
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://manns.github.io/pyspread/
+ arch = any
+ license = GPL3
+ depends = python2>=2.7.0
+ depends = python2-numpy
+ depends = wxpython
+ depends = python2-matplotlib
+ depends = cairo>=1.8.8
+ optdepends = python2-gnupg: for opening files without approval
+ optdepends = python2-xlrd: open Excel files
+ optdepends = python2-xlwt: save Excel files
+ optdepends = python2-jedi: TAB autocompletion and context help in the entry line
+ optdepends = python2-basemap: for the weather example
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/p/pyspread/pyspread-0.4.tar.gz
+ md5sums = 6188e2c4c2ed9c58add7f26b70b7e05d
+
+pkgname = pyspread
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbb19b2227a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alexander Scharinger <e1028732 at student dot tuwien dot ac dot at>
+# Contributor: Tristan Webb <t2webb@ucsd.edu>
+pkgname=pyspread
+pkgver=0.4
+pkgrel=1
+pkgdesc="A cross-platform Python spreadsheet application. Python 2.7 version"
+arch=('any')
+url="https://manns.github.io/pyspread/"
+license=('GPL3')
+depends=('python2>=2.7.0' 'python2-numpy' 'wxpython' 'python2-matplotlib'
+ 'cairo>=1.8.8')
+options=(!emptydirs)
+source=('https://pypi.python.org/packages/source/p/pyspread/pyspread-0.4.tar.gz')
+# The pyspread website lists another optional dependency: pyrsvg>=2.32, for
+# displaying SVG files in cells. I believe pyrsvg is included in cairo (from
+# the mandatory dependencies).
+# See: https://manns.github.io/pyspread/download.html and on this site follow
+# link to pyrsvg.
+optdepends=('python2-gnupg: for opening files without approval' # in AUR
+ 'python2-xlrd: open Excel files' # in Community
+ 'python2-xlwt: save Excel files' # in Community
+ 'python2-jedi: TAB autocompletion and context help in the entry line' # in Community
+ 'python2-basemap: for the weather example' ) # in Community
+md5sums=('6188e2c4c2ed9c58add7f26b70b7e05d')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+ mv $pkgdir/usr/lib/python2.7/site-packages/{changelog,README} \
+ $pkgdir/usr/lib/python2.7/site-packages/pyspread/
+}
+
+# vim:set ts=2 sw=2 et: