summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Perry (Pezz)2018-07-19 13:29:03 +1000
committerSimon Perry (Pezz)2018-07-19 13:29:03 +1000
commitee8f3f3e63f8e30d1b786d30ce716d17eb918815 (patch)
tree71abf1253315a58bd4d5f482f5ef7d008237ed21
downloadaur-ee8f3f3e63f8e30d1b786d30ce716d17eb918815.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--config.patch11
-rwxr-xr-xpyspy-start.sh4
-rwxr-xr-xpyspy.desktop10
5 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5fe1c90a789
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pyspy
+ pkgdesc = A simple EVE Online character intel tool
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/WhiteRusssian/PySpy
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-wxpython
+ depends = python-pyperclip
+ source = https://github.com/WhiteRusssian/PySpy/archive/v0.2.tar.gz
+ source = pyspy.desktop
+ source = pyspy-start.sh
+ source = config.patch
+ sha256sums = f4c4897daaa80e04dcba8c973c03d17c33117430eed6615e501aa1af52d62849
+ sha256sums = 35dd408ec9b397ca3d024b193e2fe4340b87b56a109d099de966bce1331e0744
+ sha256sums = 33156c87b96e6d747832e24156ffee31c2c03c7de1253520fe6dfbd7830349f8
+ sha256sums = a88c007e6d966af26a60a40d3aa14e36774587d8553ae9c20a4d110daabf48e6
+
+pkgname = pyspy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64a97921c3b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Simon Perry <aur [at] sanxion [dot] net>
+
+pkgname=pyspy
+pkgver=0.2
+pkgrel=1
+_distname="PySpy-${pkgver}"
+pkgdesc="A simple EVE Online character intel tool"
+arch=('any')
+url="https://github.com/WhiteRusssian/PySpy"
+license=('MIT')
+depends=('python' 'python-wxpython' 'python-pyperclip')
+optdepends=()
+source=(${url}/archive/v$pkgver.tar.gz pyspy.desktop pyspy-start.sh config.patch)
+
+sha256sums=('f4c4897daaa80e04dcba8c973c03d17c33117430eed6615e501aa1af52d62849'
+ '35dd408ec9b397ca3d024b193e2fe4340b87b56a109d099de966bce1331e0744'
+ '33156c87b96e6d747832e24156ffee31c2c03c7de1253520fe6dfbd7830349f8'
+ 'a88c007e6d966af26a60a40d3aa14e36774587d8553ae9c20a4d110daabf48e6')
+
+prepare() {
+ cd "${srcdir}/${_distname}"
+ patch -N -i "${srcdir}/config.patch"
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/pyspy
+ install -dm755 "${pkgdir}"/usr/share/licenses/pyspy
+ install -dm755 "${pkgdir}"/var/lib/pyspy
+
+ install -Dm644 "${srcdir}"/"${_distname}"/README.md "${pkgdir}"/usr/share/pyspy
+ install -Dm644 "${srcdir}"/"${_distname}"/LICENSE.txt "${pkgdir}"/usr/share/licenses/pyspy
+ install -Dm644 "${srcdir}"/"${_distname}"/VERSION "${pkgdir}"/usr/share/pyspy
+
+ cp -a "${srcdir}"/"${_distname}"/*.py "${pkgdir}"/usr/share/pyspy
+ cp -a "${srcdir}"/"${_distname}"/assets "${pkgdir}"/usr/share/pyspy
+ mv "${pkgdir}"/usr/share/pyspy/__main__.py "${pkgdir}"/usr/share/pyspy/pyspy.py
+
+ install -dm755 "${pkgdir}"/usr/share/pixmaps
+ install -Dm644 "${srcdir}"/"${_distname}"/assets/pyspy.png "${pkgdir}"/usr/share/pixmaps/pyspy.png
+
+ install -Dm644 "${srcdir}"/pyspy.desktop "${pkgdir}"/usr/share/applications/pyspy.desktop
+ install -Dm755 "${srcdir}"/pyspy-start.sh "${pkgdir}"/usr/bin/pyspy
+}
+
diff --git a/config.patch b/config.patch
new file mode 100644
index 000000000000..c169adf9f08b
--- /dev/null
+++ b/config.patch
@@ -0,0 +1,11 @@
+--- config.py.old 2018-07-18 20:35:02.000000000 +1000
++++ config.py 2018-07-19 12:58:28.279806572 +1000
+@@ -52,7 +52,7 @@
+ elif __file__:
+ ABOUT_ICON = resource_path("assets/pyspy_mid.png")
+ application_path = os.path.dirname(__file__)
+- PREF_PATH = os.path.join(application_path, "tmp")
++ PREF_PATH = os.path.expanduser("~/.config/pyspy")
+ if not os.path.exists(PREF_PATH):
+ os.makedirs(PREF_PATH)
+ LOG_PATH = PREF_PATH
diff --git a/pyspy-start.sh b/pyspy-start.sh
new file mode 100755
index 000000000000..cc8d73b7a515
--- /dev/null
+++ b/pyspy-start.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+/usr/bin/python /usr/share/pyspy/pyspy.py
+
diff --git a/pyspy.desktop b/pyspy.desktop
new file mode 100755
index 000000000000..899cb6c25d6c
--- /dev/null
+++ b/pyspy.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=0.2
+Encoding=UTF-8
+Name=PySpy
+Comment=PySpy
+Exec=/usr/bin/pyspy
+Terminal=false
+Icon=pyspy
+Type=Application
+Categories=Application;Game;