summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2015-07-02 15:27:52 +0200
committerBalló György2015-07-02 15:27:52 +0200
commitf59498fe9e17d210591410cf11c582eee705a952 (patch)
tree2ef5de26ebd1f61d18dde0c08e99583870b39320
downloadaur-f59498fe9e17d210591410cf11c582eee705a952.tar.gz
upgpkg: pysztaki-svn 9-3
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE41
-rw-r--r--PKGBUILD43
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0919ae71659c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pysztaki-svn
+ pkgdesc = Translator script for console using the szotar.sztaki.hu database
+ pkgver = 9
+ pkgrel = 3
+ url = http://code.google.com/p/pysztaki/
+ arch = any
+ license = BSD
+ makedepends = subversion
+ depends = python2-beautifulsoup3
+ source = pysztaki::svn+http://pysztaki.googlecode.com/svn/trunk/
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 73c04eba22d5814ff62c1b2dc8f446c5
+
+pkgname = pysztaki-svn
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..90eb167c25a8
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,41 @@
+PySztaki
+Translator script for console using the szotar.sztaki.hu database
+
+A really short script, which uses the given dictionary (in first
+parameter) to translate a word or an expression. It uses web-based
+translator of szotar.sztaki.hu (parsed with BeautifulSoup
+http://www.crummy.com/software/BeautifulSoup/). The translate()
+function contains the actual translation code, it can be simply
+reused.
+
+Script home:
+http://pysztaki.googlecode.com/
+
+Copyright (c) 2008, Pek Daniel
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the <ORGANIZATION> nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f78128a25a29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=pysztaki-svn
+_pkgname=pysztaki
+pkgver=9
+pkgrel=3
+pkgdesc="Translator script for console using the szotar.sztaki.hu database"
+arch=('any')
+url="http://code.google.com/p/pysztaki/"
+license=('BSD')
+depends=('python2-beautifulsoup3')
+makedepends=('subversion')
+source=("$_pkgname::svn+http://pysztaki.googlecode.com/svn/trunk/"
+ 'LICENSE')
+md5sums=('SKIP'
+ '73c04eba22d5814ff62c1b2dc8f446c5')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ svnversion | tr -d [A-z]
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ # Fix SZTAKI URL
+ sed -i 's|http://szotar.sztaki.hu|http://regiszotar.sztaki.hu|' pysztaki/sztakiconfig.py
+
+ # Fix encoding
+ sed -i 's|iso8859-2|utf-8|' sztaki.py
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ ln -s sztaki.py "$pkgdir/usr/bin/pysztaki"
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}