summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 19:10:19 +0200
committerMattias Andrée2015-06-11 19:10:19 +0200
commit7ec63a7571ae013ae4d4c0f79d6c150ee4d4563e (patch)
tree8225e50c8516ab02079b33066975a975e42b8b35
downloadaur-7ec63a7571ae013ae4d4c0f79d6c150ee4d4563e.tar.gz
Initial import, version 1417073566
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b6ce814c32f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pytagomacs
+ pkgdesc = An Emacs like key–value editor library for Python
+ pkgver = 1417073566
+ pkgrel = 1
+ url = https://github.com/GNU-Pony/pytagomacs
+ arch = any
+ license = GPL3
+ makedepends = make
+ makedepends = coreutils
+ makedepends = python3
+ depends = python3
+ depends = coreutils
+ source = https://github.com/GNU-Pony/pytagomacs/archive/1417073566.tar.gz
+ sha256sums = 3b492aed48e0ea5d0d42c8b2189a2db9472d54e68e050be527a30f91e49516d2
+
+pkgname = pytagomacs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4fadaee9311
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=pytagomacs
+pkgver=1417073566
+pkgrel=1
+pkgdesc="An Emacs like key–value editor library for Python"
+url="https://github.com/GNU-Pony/pytagomacs"
+arch=(any)
+license=(GPL3)
+depends=(python3 coreutils)
+makedepends=(make coreutils python3)
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(3b492aed48e0ea5d0d42c8b2189a2db9472d54e68e050be527a30f91e49516d2)
+
+
+build() {
+ cd "${srcdir}/pytagomacs-${pkgver}"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR=4
+}
+
+package() {
+ cd "${srcdir}/pytagomacs-${pkgver}"
+ make PREFIX=/usr PY_MAJOR=3 PY_MINOR=4 DESTDIR="${pkgdir}" install
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+