summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Kubosz2017-05-04 17:48:17 +0200
committerRobert Kubosz2017-05-04 17:48:17 +0200
commit35c6ba3761d2e68d866fb2ca16f452a2998eda70 (patch)
treecc26c4a72e7bc364611343b699733d4b2ab4fb24
parentc5560e53492d7b14c7672a365567b25778c05b1e (diff)
downloadaur-35c6ba3761d2e68d866fb2ca16f452a2998eda70.tar.gz
add optional dependencies
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD16
2 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91da01a3ec4f..c94f5f1703c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,19 +5,37 @@ pkgbase = python-abjad
url = https://github.com/Abjad/abjad
arch = any
license = GPL 3
+ depends = lilypond
optdepends = graphviz: to create rhythm-trees graphs and other tree structures
+ optdepends = timidity: to play generated MIDI files
+ optdepends = jupyter: browser-based interactive notebook for programming
source = https://github.com/Abjad/abjad/archive/v2.20.tar.gz
sha256sums = c8ba4ea9707ba87e9a2ede40c97d14d6b6c701ae884667dcd44c828a50c97cb0
pkgname = python-abjad
pkgdesc = Formalized music score control. Package for Python 3
- depends = python
depends = lilypond
+ depends = python
depends = python-ply
+ depends = python-six
+ optdepends = graphviz: to create rhythm-trees graphs and other tree structures
+ optdepends = timidity: to play generated MIDI files
+ optdepends = jupyter: browser-based interactive notebook for programming
+ optdepends = ipython: an enhanced Python console
+ optdepends = python-ipywidgets: IPython widgets for Jupyter notebook
+ optdepends = python-pypdf2: PDF toolkit
pkgname = python2-abjad
pkgdesc = Formalized music score control. Package for Python 2
- depends = python2
depends = lilypond
+ depends = python2
depends = python2-ply
+ depends = python2-six
+ optdepends = graphviz: to create rhythm-trees graphs and other tree structures
+ optdepends = timidity: to play generated MIDI files
+ optdepends = jupyter: browser-based interactive notebook for programming
+ optdepends = ipython2: an enhanced Python 2 console
+ optdepends = python2-ipykernel: Python 2 support for Jupyter
+ optdepends = python2-ipywidgets: IPython2 widgets for Jupyter notebook
+ optdepends = python2-pypdf2: PDF toolkit
diff --git a/PKGBUILD b/PKGBUILD
index c8660aba3b4b..1ce949e0ce33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,10 @@ pkgdesc="Formalized music score control. Package for Python"
arch=('any')
url="https://github.com/Abjad/abjad"
license=('GPL 3')
-optdepends=('graphviz: to create rhythm-trees graphs and other tree structures')
+depends=('lilypond')
+optdepends=('graphviz: to create rhythm-trees graphs and other tree structures'
+ 'timidity: to play generated MIDI files'
+ 'jupyter: browser-based interactive notebook for programming')
source=("$url/archive/v$pkgver.tar.gz")
sha256sums=('c8ba4ea9707ba87e9a2ede40c97d14d6b6c701ae884667dcd44c828a50c97cb0')
@@ -17,8 +20,11 @@ prepare() {
}
package_python-abjad() {
- depends=('python' 'lilypond' 'python-ply')
+ depends+=('python' 'python-ply' 'python-six')
makedepends=('python-setuptools')
+ optdepends+=('ipython: an enhanced Python console'
+ 'python-ipywidgets: IPython widgets for Jupyter notebook'
+ 'python-pypdf2: PDF toolkit')
pkgdesc+=" 3"
cd $srcdir/abjad-$pkgver
@@ -29,8 +35,12 @@ package_python-abjad() {
}
package_python2-abjad() {
- depends=('python2' 'lilypond' 'python2-ply')
+ depends+=('python2' 'python2-ply' 'python2-six')
makedepends=('python2-setuptools')
+ optdepends+=('ipython2: an enhanced Python 2 console'
+ 'python2-ipykernel: Python 2 support for Jupyter'
+ 'python2-ipywidgets: IPython2 widgets for Jupyter notebook'
+ 'python2-pypdf2: PDF toolkit')
pkgdesc+=" 2"
cd $srcdir/abjad-$pkgver-python2