summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Kubosz2018-01-30 11:39:22 +0100
committerRobert Kubosz2018-01-30 11:39:22 +0100
commitccf087255369243892f7cb70cbee1dcd292c2286 (patch)
tree796b7363ccae6860aafde057877c20c0964485cb
parentbe1a6a2b5debd801dfa44f334ee32d504cd66e15 (diff)
downloadaur-ccf087255369243892f7cb70cbee1dcd292c2286.tar.gz
added back python2 support
There were some issues with python2 packages. I solved the dependencies of python2-abjad package and marked the python2-abjad and python-abjad both in conflict, since there are colliding files. Now it build with some unimportant errors (in test suites probably), but it still works fine.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
2 files changed, 58 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2c959545091..3a7a967c6e41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,10 +6,8 @@ pkgbase = python-abjad
arch = any
license = GPL 3
makedepends = python-setuptools
+ makedepends = python2-setuptools
depends = lilypond
- depends = python
- depends = python-ply
- depends = python-six
optdepends = graphviz: to create rhythm-trees graphs and other tree structures
optdepends = fluidsynth: to play generated MIDI files (instead of timidity++)
optdepends = timidity++: to play generated MIDI files (instead of fluidsynth)
@@ -22,4 +20,22 @@ pkgbase = python-abjad
sha256sums = 5fc1fc977b9521d4b9ce1aa8bdea1aa07306e313bd03feea15e8c680b4f27c5b
pkgname = python-abjad
+ depends = lilypond
+ depends = python
+ depends = python-ply
+ depends = python-six
+ conflicts = python2-abjad
+
+pkgname = python2-abjad
+ depends = lilypond
+ depends = python2
+ depends = python2-ply
+ depends = python2-six
+ depends = python2-mock
+ depends = python2-funcsigs
+ depends = python2-enum34
+ depends = python2-pathlib2
+ depends = python2-scandir
+ provides = python-abjad
+ conflicts = python-abjad
diff --git a/PKGBUILD b/PKGBUILD
index 04c194ed7a26..593b8f6764c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,16 @@
# Maintainer: Robert Kubosz <kubosz.robert@gmail.com>
-pkgname=python-abjad
+pkgbase=python-abjad
+pkgname=(python-abjad python2-abjad)
pkgver=2.21
pkgrel=2
pkgdesc="Tool for formalized music score control."
arch=("any")
url="https://github.com/Abjad/abjad"
license=("GPL 3")
-depends=(
- "lilypond"
- "python"
- "python-ply"
- "python-six"
- )
-makedepends=("python-setuptools")
-conflicts=('python2-abjad')
+depends=("lilypond")
+makedepends=("python-setuptools" "python2-setuptools")
+conflicts=("python2-abjad")
optdepends=(
"graphviz: to create rhythm-trees graphs and other tree structures"
"fluidsynth: to play generated MIDI files (instead of timidity++)"
@@ -27,14 +23,47 @@ optdepends=(
source=("$url/archive/v$pkgver.tar.gz")
sha256sums=("5fc1fc977b9521d4b9ce1aa8bdea1aa07306e313bd03feea15e8c680b4f27c5b")
+prepare () {
+ cp -rup $srcdir/abjad-$pkgver $srcdir/abjad-$pkgver-python2
+}
+
build() {
cd $srcdir/abjad-$pkgver
python setup.py build
+
+ cd $srcdir/abjad-$pkgver-python2
+ python2 setup.py build
}
-package() {
+package_python-abjad() {
+ depends+=(
+ "python"
+ "python-ply"
+ "python-six"
+ )
+ conflicts=("python2-abjad")
+
cd $srcdir/abjad-$pkgver
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
+package_python2-abjad() {
+ depends+=(
+ "python2"
+ "python2-ply"
+ "python2-six"
+ "python2-mock"
+ "python2-funcsigs"
+ "python2-enum34"
+ "python2-pathlib2"
+ "python2-scandir"
+ )
+ conflicts=("python-abjad")
+ provides=("python-abjad")
+
+ cd $srcdir/abjad-$pkgver-python2
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+