summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2024-05-10 19:50:27 +0800
committerUniversebenzene2024-05-10 19:50:27 +0800
commitb97a361a580d729ebe2f958a923c2b37b63e7221 (patch)
tree85806b020090a97300d9fde3814a694889f7fb17
parent0fda0e12da5b0818bdff357e34e69b500ef0f7b4 (diff)
downloadaur-b97a361a580d729ebe2f958a923c2b37b63e7221.tar.gz
Update to version 0.0.5
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b55ae4dd8ac..a1f0a42d8db0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = python-accessible-pygments
pkgdesc = A collection of accessible pygments styles
- pkgver = 0.0.4
+ pkgver = 0.0.5
pkgrel = 1
url = https://quansight-labs.github.io/accessible-pygments
arch = any
- license = BSD
+ license = BSD-3-Clause
checkdepends = python-nose
- makedepends = python-setuptools
- makedepends = python-pygments
- source = https://files.pythonhosted.org/packages/source/a/accessible-pygments/accessible-pygments-0.0.4.tar.gz
- md5sums = ecacd117d7258a285ccc282a33abd906
+ makedepends = python-hatchling
+ makedepends = python-hatch-fancy-pypi-readme
+ makedepends = python-hatch-vcs
+ makedepends = python-build
+ makedepends = python-installer
+ source = https://files.pythonhosted.org/packages/source/a/accessible_pygments/accessible_pygments-0.0.5.tar.gz
+ md5sums = 3b3ce27e8340fad9f60cb3a633265566
pkgname = python-accessible-pygments
depends = python-pygments>=1.5
diff --git a/PKGBUILD b/PKGBUILD
index 8e1d5351cc14..1a74641b90d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-accessible-pygments
-_pyname=${pkgbase#python-}
-pkgname=("python-${_pyname}")
+_pname=${pkgbase#python-}
+_pyname=${_pname//-/_}
+pkgname=("python-${_pname}")
#"python-${_pyname}-doc")
-pkgver=0.0.4
+pkgver=0.0.5
pkgrel=1
pkgdesc="A collection of accessible pygments styles"
arch=('any')
url="https://quansight-labs.github.io/accessible-pygments"
-license=('BSD')
-makedepends=('python-setuptools'
- 'python-pygments')
+license=('BSD-3-Clause')
+makedepends=('python-hatchling'
+ 'python-hatch-fancy-pypi-readme'
+ 'python-hatch-vcs'
+ 'python-build'
+ 'python-installer')
+# 'python-pygments'
# 'python-wheel'
-# 'python-build'
-# 'python-installer'
# 'python-sphinx')
checkdepends=('python-nose')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('ecacd117d7258a285ccc282a33abd906')
+md5sums=('3b3ce27e8340fad9f60cb3a633265566')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
-# python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation
# msg "Building Docs"
# PYTHONPATH="../build/lib" make -C docs html
@@ -42,8 +44,7 @@ package_python-accessible-pygments() {
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
-# python -m installer --destdir="${pkgdir}" dist/*.whl
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
#package_python-accessible-pygments-doc() {