summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonian Guveli2018-11-13 17:53:57 +0200
committerJonian Guveli2018-11-13 17:53:57 +0200
commitbb3d21ff6e9653f730660a9ac33bb91e90bdae18 (patch)
tree57e154736479f81012b0529c73d5aaca4bc3cf3c
downloadaur-bb3d21ff6e9653f730660a9ac33bb91e90bdae18.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d48d686ffe25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-acestream
+ pkgdesc = Python interface to interact with the AceStream Engine and the HTTP API
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/jonian/python-acestream
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ optdepends = acestream-engine: AceStream local server
+ conflicts = python-acestream
+ conflicts = python-acestream-git
+ source = python-acestream-0.1.3.tar.gz::https://github.com/jonian/python-acestream/archive/v0.1.3.tar.gz
+ md5sums = 771047c80c03721a45e676bcd38fbb14
+
+pkgname = python-acestream
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d861a8edfc1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=python-acestream
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Python interface to interact with the AceStream Engine and the HTTP API"
+arch=("any")
+url="https://github.com/jonian/python-acestream"
+license=("GPL")
+depends=("python")
+optdepends=("acestream-engine: AceStream local server")
+makedepends=("python-setuptools")
+conflicts=("${pkgname}" "${pkgname}-git")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+md5sums=("771047c80c03721a45e676bcd38fbb14")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}