summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2016-04-18 19:53:48 +0200
committerGordian Edenhofer2016-04-18 19:53:48 +0200
commitdc45f7d8bf402aee4782bb2da80068e82d458872 (patch)
treee8288d430ca1cc3cb82dc2ede7fea8f55efbdb58
parent5a7293a41f5bf870099182538de7406db10c35c0 (diff)
downloadaur-dc45f7d8bf402aee4782bb2da80068e82d458872.tar.gz
Upgpkg: 0.5.0.r57.g86e09d5-1
Mention pkgver in provides field for better dependency handling.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28562a926d51..765f0b876053 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -43,7 +43,7 @@ pkgname = python-acme-git
depends = python-six
depends = python-werkzeug
depends = python-mock
- provides = python-acme
+ provides = python-acme=0.5.0.r57.g86e09d5
conflicts = python-acme
pkgname = python2-acme-git
@@ -58,5 +58,5 @@ pkgname = python2-acme-git
depends = python2-six
depends = python2-werkzeug
depends = python2-mock
- provides = python2-acme
+ provides = python2-acme=0.5.0.r57.g86e09d5
conflicts = python2-acme
diff --git a/PKGBUILD b/PKGBUILD
index 5cd9286a46a6..1c34b9fbe51e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,7 +51,7 @@ package_python-acme-git() {
depends=('python-setuptools' 'python-pyasn1' 'python-cryptography' 'python-pyopenssl'
'python-ndg-httpsclient' 'python-pyrfc3339' 'python-pytz' 'python-requests'
'python-six' 'python-werkzeug' 'python-mock')
- provides=("python-acme")
+ provides=("python-acme=${pkgver}")
conflicts=("python-acme")
cd "${srcdir}/${_reponame}/acme"
@@ -62,7 +62,7 @@ package_python2-acme-git() {
depends=('python2-setuptools' 'python2-pyasn1' 'python2-cryptography' 'python2-pyopenssl'
'python2-ndg-httpsclient' 'python2-pyrfc3339' 'python2-pytz' 'python2-requests'
'python2-six' 'python2-werkzeug' 'python2-mock')
- provides=("python2-acme")
+ provides=("python2-acme=${pkgver}")
conflicts=("python2-acme")
cd "${srcdir}/${_reponame}/acme-py2"